Automatically changing spaces when connect to external monitor

I’ve recently purchased an Apple Thunderbolt display (TBD) for use with my 2013 Retina Macbook Pro (MBP). I don’t have separate spaces set up for the TBD and MBP and I’m not mirroring spaces between the two screens. I’m simply using the TBD as a replacement screen when at home. I’m finding that the spaces automatically change when I plug in the MBP to the TBD and then close the MBP lid. This behaviour only happens after I close the MBP lid. It also doesn’t happen if I close TotalSpaces and just use Apple’s built in spaces feature. Typically the space changes to the left or the right and it continues to happen about every 3 or 4 seconds. I’m hoping there may be some sort of a fix for this problem.


I should have also mentioned that if I keep the BMP lid closed and reboot the computer then the behaviour stops. Don’t really want to have to reboot the computer every time I plug into the TBD though.

Thanks for your assistance,

Do you by any chance have “Change space by moving mouse to the edge of the screen” enabled in Transitions preferences?

I’m wondering if TotalSpaces2 believes that you are trying to trigger space changes that way for some reason.

I have tried to reproduce this with my external display, but it’s not doing it for me, so I need to try to figure this out remotely.

The space changes must be triggered by something, the options are keyboard events, trackpad events, or for some reason the system is demanding space changes.

Do you have swipe to change space turned on in Transitions prefs? And is there anything relevant in the logs when this happens?

I’ve done some further experiments with this, and I do see some problems when the lid is closed due to the internal trackpad remaining active.

I have a potential fix for this. Please could you try this version and let me know if it helps?

I get this exact issue too, whenever I plug in my external monitor and close the laptop lid (which I do several times per day). It does seem to stop though after a few minutes of seemingly random switching. I’ll try that new version and report back.

So far so good.

Great, thanks for letting me know