Broken* Spaces, Undeletable spaces.plist -- *"Fixed"

Update: 1) This has nothing to do with TotalSpaces2 and 2) I may have “fixed” this - Just discovered that the ‘add space’ icon is appearing at the top left corner of the Mission Control grid, rather than top right. The newly spawned space jumps over and around the row of existing spaces to take its place at the end! Very weird and counterintuitive behavior. Not sure what causes it…

(How I know it doesn’t have anything to do with TotalSpaces2 - did a full wipe, restored from a backup that didn’t have TotalSpaces or the spaces.plist file. For a while, the ‘add new space’ icon was appearing on the right as before. Then it suddenly stopped appearing - I was checking frequently. Not sure what caused that.

For some reason, I moused over to the left corner, and discovered that the icon popped out there! Not sure why this happens, and I would like it to go back to the default behavior, but for now I’ll take it. Hopefully it won’t change for the worse now.

Leaving the details here so if anybody else has the same problem, they can hopefully find it.)

Hey Stephen -

I was trying out TotalSpaces2 on Mavericks (on a new machine) and it might have broken something - except for using TotalSpaces, I can’t make new spaces anymore! (When I go into mission control and take my mouse pointer to the upper right corner, the + sign with a new space does not appear!) I was hoping you might have some thoughts…

To fix the problem, I tried deleting the .plist file (~/Library/Preferences/ (and the associated .lockfile and some backup file - but the .plist seems to be protected somehow.

The other two files stay deleted, but although a new “default” plist appears in the folder, it gets automatically replaced with the previous version fairly quickly - and definitely if I log out and back in.

In any case, the temporary deletion doesn’t really help either - can’t make new spaces even with new default .plist file. I’m guessing this has something to do with the active copy of the plist being in memory?

The undeletability probably results from some combination of the file permissions and time machine working together to restore what the system sees as the “wrong” file there?

I haven’t been able to find any ways of fixing this… (Tried deleting backup copies of the .plist through time-machine, didn’t work…)

Hopefully you or someone else on the forum can help! Thanks a bunch for any pointers. Let me know if I can provide more info.

(BTW, on another machine still running Mountain Lion the exact same .plist works just fine. These are both MacBook Pros, the ML one is a 2007 15" Santa Rosa MBP, Mavericks is on a new 2013 15" Haswell rMBP. I use both machines with an external 27" Monoprice display as well as by themselves. The spaces behavior problem appears regardless of whether the external display is connected.)

Hi! Glad you solved it.

When I have my Dock set to the right side of the screen, the plus button appears on the left. But when I have it on the left, it appears on the right. When I have it at the bottom, it goes on the right.

But that’s all I know about the mechanics of that button - maybe there are some other factors that affect it also. Of course, if you have TotalSpaces installed you can use the Layout preferences to add spaces.

Yes - it is the Dock position! I guess this is expected behavior then, though very difficult to discover (and not clear whether it’s suppose to be a feature for some reason*)…

In fact, I’ve been using the right-side Dock for a few weeks now… just never had to add a space in that time… So the fact that the Dock position could have anything to do with this didn’t occur to me.

Oh well…

Update: Apparently this is to enable people with very long Docs on the right edge to be abel to use the ‘add new space’ icon. The icon would otherwise get covered up -