Calculate All Sizes option not sticking as default

I have gone into view options and checked “Calculate all sizes” and then clicked to make it default.

This works when totalfinder is not loaded. Once I use total finder though each new tab is has to be enabled separately.

Way to fix this?