Cannot instal totalspaces on Catalina

I keep getting an error when installing totalspaces,

“installation error moving OSAX into place”

I have tried uninstalling and reinstalling but no joy same error

I was really hoping to try this app. any help would be great.



Same here running 10.15 Beta (19A501i).

yes I am running 10.15 Beta (19A501i) too.

bump any support staff checking this forum?

FWIW, I’m running this same version of Catalina on my 2018 MacBook Pro and TotalSpaces2 (v.2.8.0) is working without any problems.

Ok just tried that version 2.8.0 and still getting same problem.

Yeah, I think it was because I already had TotalSpaces installed when I upgraded to Catalina…

any help would be appreciated.

Hey guys, so basically here is what’s up. If you are running the Catalina beta you must

  1. make sure that SIP is off.

Unlike before, this still does not mount protected parts of the file system into read-write mode by default. So there is one more step.

  1. Run: sudo mount -uw /

This will remount your filesystem with write permissions until restart. This should allow TotalSpaces (and any other relevant app) to install things into /system or wherever else SIP protects.

Let me know if you run into problems!


1 Like

It works now. Thank you, Sam.