Chrome always opens in second space - even after uninstalling TotalSpaces

I was testing TotalSpaces and I have one big problem now… not sure if TS is the cause… but I cannot get my second instance of Chrome to open normally in the default space… it always opens in the second one. It may be related to the external monitor I connected recently though. I uninstalled TS with an uninstaller and still there’s a problem… Do you have any suggestions on how to resolve this?

Here is the video:

thank you!

The space assignments are managed by the system, and are held in the file ~/Library/Preferences/

Perhaps there is something awry in there - do you have Xcode installed or something you can examine the file with?

I would add that Chrome has never worked terribly well with spaces - for example: and!topic/chrome/Exf2Sf0Bev8 - I don’t know if there remain some issues - I generally avoid assigning chrome to a particular space because of similar issues I’ve had in the past.

I deleted ~/Library/Preferences/ multiple times already … didn’t help… I have xcode but I’m not sure if I could troubleshoot this…

I have set up this instance of Chrome for web development with this tutorial:

I now tried to setup another one and actually this also opens in second space - strange… and it also doesn’t have “Assign to” options.

Maybe that’s too much “hacking” for OSX… I guess I just won’t do it then… it turns out that I cannot change the icon either - I wanted Chromium blue for my development instance but it keeps turning back. So without icon and with spaces problems I just won’t use that… hope this doesn’t happen in any normal apps.

thank you for helping

Actually I seem to have a big problem… I dismissed the other instance now and the main Chome instance is in the right space but when I try to login with Google or Facebook on some sites, I’m thrown to the second space… and without windows! This is quite nasty…

and also now when I try to move back to first space, I’m thrown back to the second one immediately… this is not shown in the gif above… What can I do, it’s terrible? Any ideas maybe? Thank you

Fixed it… the main Chrome app seemed to be assigned to the second desktop… and this is also the cause of the first problem… actually it’s normal that I cannot assign the dev instance to any desktop… it just uses the main instance which it’s using “under the hood”. I was confused because I think the main instance opened in the main space but I’m not sure anymore, maybe I didn’t really check when this started… now I have both instances opening in the main space.

You can close this ticket. Thank you

Ah, I see now - because the apps are using the same bundle identifier probably.

Thanks for letting me know!