Creating New Tab Creates New Window

All of a sudden when I create a new tab, either via shortcut or via the button in the tab bar, a new window is created instead of a tab.

Is there a preference file I need to delete somewhere?

I generally use the Visor as my Finder and never run any floating windows.

This one might be related

would love to get an answer on this


Do you guys use spaces? Or do you have TotalFinder window hidden or minimized?

The logic which decides if tab or new window should be opened is quite complex. If you have default settings and opening tab in non-visor window I look for last active tab window on current space (and this method has some problems, because hidden/miniaturized windows are not counted to be on any space).

We have two tweaks which alter the behaviour:

The first one forces all new tabs created to appear in Visor window (this is a hack for people who use Visor exclusively):

defaults write TotalFinderAlwaysUseVisorForNewTabs -bool YES

The second one forces all tabs to open in a new window regardless:

defaults write TotalFinderDontMakeTabs -bool YES
1 Like

All I want is for total finder to always open a new finder tab in the 1 main finder window that I use. Not in a new finder window or the visor.

I tried changing the boolean ‘yes’ to a ‘no’ and am not getting the results I want.
again, here is my desired workflow, this is the way total finder worked in snow leopard for me:

I want one Finder window with all my tabs and for Finder to have it’s own space in Mountain Lion. I like not having many finder windows open.

I do use spaces and I have one space with only finder in it. So, I will never have a situation where a new tab is created via another application from that space
If I do ‘show in finder’ or ‘reveal in finder’ from any application in a diff space, i get a tab opens in a new window.
Also, from spotlight, If i’m searching from a diff space, i get a tab opens in a new window.
How do I get total finder to behave the way i have described above?


Setting that preference got TotalFinder working again for me.

which one? and what did it get working?


any word on this?

no response from the dev? Thats just plain rude. At least tell me that you are not going to fix this


I’m sorry, this topic somehow went off my radar,

  1. Please stop using this command in

    osascript -e “tell application “Dock” to quit”

  2. Move Finder’s plist away:

    mv ~/Library/Preferences/ ~

  3. open /Applications/

This will delete all your Finder and TotalFinder settings to factory defaults. I hope it will solve the issues.

I’m having the same problem. Mac OS X 10.8.5, on a Mac Pro. This started a couple of days ago for me. Following the instructions from Darwin didn’t help at all, unfortunately.

I just downloaded version 1.4.18, the latest offered in the downloads section, and after uninstalling TotalFinder, and reinstalling, it seems to be working correctly.

no luck with the terminal commands you mentioned- or reinstalling the lates version…still opens up in a new window.
any other ideas?