Cut/Paste, Drag&Drop and New Folder features are gone and did not return with 1.6

Long time user of TF. Frequent problem was the visor quit working and the icon would disappear from the finder prefs menu. No biggie, usually a restart or reloading TF would fix things. Less than a week ago using 1.5… I had to reload the app to get it back. It made no mention nor did it detect the 1.6 update. Thought everything was ok then realized that I no longer had ANY drag and drop abilities, no cut and paste and the New Folder option was no longer highlighted in the drop down menu. Dead in the water. I could drag something and when it got to the desktop or another destination icon would be overwritten by a white circle with a line through it. Apple tech spent hours with me today to no avail. Reloaded the system, nothing worked. Created another user account, logged on to that one and every drag and drop/folder feature returned. It is not a hardware issue. Upgrading to TF 1.6 did nothing to change things. I’m looking for some guidance past this issue. Also, uninstalling TF made no difference.

Hi Steve,

Finally I’m catching up with remaining forum posts. This looks like a deeper problem if it affected also plain Finder.

Have you tried to trash Finder preferences in ~/Library/Preferences/