Delay at window opening since 1.4.x

I’m using TotalTerminal for a long time and really love this product, thank you guys!
However ever since I’ve updated to 1.4.2 (and .3 and .4 later) I’m experiencing small but very annoying problem — there’s a delay between the moment I press a hotkey and the moment when terminal appears. Delay is quite big and easy noticeable, about 1 sec. TotalTerminal 1.3 didn’t have this problem so I’ve downgraded back to 1.3 now. My Mac is running Mountain Lion (10.8.5).
Does anyone have the same problem?

I don’t see the problem on my 10.8.5 system. Anyone?

Just to make sure I explained it right: I saw a delay if Terminal was NOT active, for instance if I worked in Intellij IDEA, pressed Control + Control to open terminal, then only after ~1 sec sliding animation begins. But if after that I hide terminal (but not switch to another app) and press hotkey again, terminal will appear immediately. Hope it’ll help.

I’m also seeing the same issue on OSX 10.8.5 and TT v1.4.4. My colleague (same OSX version) is on TT v1.3 and does not have the issue. Let me know if you need any other info.

This should be fixed in 1.4.5:

Confirm, problem is solved in 1.4.5. Thank you very much!

1 Like

Thanks for the quick turnaround!!

Confirmed on 10.9. I’ll check my 108.5 install Monday morning.

1.4.5 regresses in two ways:

  • On startup the visor takes over the screen instead of opening in the background. I see it briefly open a “normal” terminal window (which it never seemed to do before) and then it disappears and becomes a visor, covering the desktop.
  • It introduced a new delay that makes it unusable when trying to dismiss the visor, or cmd-tabbing to and from Terminal.

Whereas in the past I could bring up the visor and make it go away with two keystrokes in succession (say, across 1 second), now there’s a long delay after the visor is brought up, during which another keypress will not make it go away and is lost. Note, I use no animations, fades, etc., it opens full screen on the main monitor only.

This is visible if you turn on fade for 0.1 seconds and try to rapidly make the visor disappear – you can see the faded visor covering the desktop for a heartbeat before it vanishes.

Note: I am on Mavericks.

I’m unable to uninstall and reinstall 1.4.3 or older, now. Every version exhibits this behavior. I’m gonna keep debugging…

I was finally able to reinstall 1.4.4 and return functionality after manually editing the terminal plist and setting TotalTerminalVisorAnimationSpeed to 0 (0.1 still exhibits the problem). It seems that TT is ignoring that value of zero in 1.4.5 and still applying a non-zero value somewhere, even though this should only affect animations, which I am not using.