Desktop number in icon missing in MacOS 10.14 Mojave light mode

I just upgraded to 10.14, installed TotalSpaces2 v2.7.5.

Functionality looks good, but the desktop number in the icon in the menu bar is missing when in light mode. (It is present in dark mode) Interestingly, the desktop number becomes visible during a mouse click on the icon.

Update: I just found mention of this issue on the end of the other 10.14 thread. Sorry.

Yes, thanks for the report. It only happens on some machines, I hope to have a fix shorty.

1 Like

I just discovered that it’s missing when I have System Preferences -> Accessibility -> Display -> Reduce transparency set, but when it’s unset I the number is displayed normally. It only seems to matter in System Preferences -> General -> Light mode.

Hope that helps.

Hi, yes it’s reduce transparency that does it. For some reason the number which should normally be white renders completely transparent (so you can’t see it) when reduce transparency is set, and light mode is selected.

It’s a weird bug, I’ll try to find a workaround.

I’ve actually turned off the mode at the moment, not because of the issue in TotalSpaces, but because of some of the “choices” (which could easily be bugs) MacOS have made. Some notification centre boxes (e.g. from Calendar) end up being black on a dark grey.

I don’t know whether it’s “artistic differences” between what I would prefer and what the Apple designers have decreed, but light mode tends to end up being a bit of an appalling mess at the moment. Some parts of light mode look positively anaemic, while other parts become too dark and would look better in dark mode.

I’m off to find some defaults I can change to make this look better, and as always - thanks for an excellent product.

I did find a workaround, but there is a bit more work to do with the menu bar icon to make it behave properly when there are multiple monitors connected. Anyway, expect a fix in the next update.

This version fixes a few bugs, including this issue.

Release notes here:

1 Like

That nailed it. Thanks!