Editing filenames bug

I also have the same problem for a while now. Not sure when it started but it has been quite a few months. Since it is so intermittent, it hasn’t been a problem but figured I’d report it anyways.

Like musicman, I’m not using Visor at all (it is disabled in the prefs) so it isn’t directly related to that feature.
It happens whether there are 1 or more windows open and if the window has tabs or not so again, not directly related.

When it happens, any arrow or letter keypresses just cause a system beep. I haven’t had a chance to test CTRL+TAB to switch tabs as mentioned in the other thread.

I’ve found 2 ways to get it working properly again.

  1. Wait. After about 30 seconds, everything starts responding normally. Is there a timeout loop happening that is getting stuck?
  2. Switch to another app then back. I can simply click on another app window in the background then back to the TotalFinder window and the keyboard starts working normally.

Perhaps those can point you in the right direction of this annoying bug.

Also, I’m happy to do additional testing. There isn’t anything logged to the console so do you have a hidden function to enable debug logging or could you send me a special debug logging version?

Thanks and I hope we can resolve this one soon.

Using TotalFinder 1.6.2 on OSX 10.9.4

Over a month now and this is still a significant problem. Please escalate if possible.


I’ve had the same issue off and on for months and reported it way back when via email. It’s intermittent but loss of keyboard focus on the intended window is pretty frustrating. I can usually “fix” it by clicking around other windows / tabs or opening a new window, navigating around with the arrow keys, closing that window, and keyboard focus usually goes back to normal fairly quickly.

Sometimes I get the system beep when focus is lost, and other times focus seems to be “stuck” in another window. I can have two windows / tabs open, each with a folder or file “selected” but I’m only able to control the “stuck” one. It’s definitely not limited to Visor.

I hear you, guys. Will try to investigate and fix it ASAP.

was going to create a new topic, but luckily found this…

I’ve been having this issue for a while now… no response after changing and editing filenames…

was having them much less before… but now the frequency has increased to almost every time i edit a filename… its frustrating!!! i can’t edit any of the new albums in my collection without touching my trackpad again and again…

please fix this soon @darwin!!!

Good news. Found 100% reproducible steps with Visor plugin completely disabled.

  1. Open TotalFinder window, with single tab, in list view
  2. Enter edit mode on some file [ENTER]
  3. Resize window while in edit mode via mouse dragging bottom-right corner (this will forcibly exit edit mode)
  4. Enter edit mode again (any file) and press ESC (or perform some editing and hit ENTER)
  5. Keyboard input is stuck and beeping

It looks like unexpected interruption of edit mode in step 3 confused Finder and problem gets exposed next time exiting edit mode. I’m looking for explanation and some stable solution.

btw. I assume there may be other workflows which trigger unexpected interruption of edit mode similar to step 3. For example Visor sliding down while in edit mode could cause similar problem.

Just a quick update. While looking for solution to this problem, I have discovered much better way how to glue Finder and TotalFinder windows with regards to keyboard focus. This allowed me to remove tons of hacks previously I had to implement to emulate proper keyboard focus between Finder and TotalFinder windows.

In the next version 1.6.10, there will be this new system in place. It will lead to more stable and predictable TotalFinder behaviour.

Maybe this will introduce some other edge cases, but I’m pretty sure I will be able to fix them in next few releases. But great news is that this bug will be history!


TotalFinder 1.6.10 should fix all issues with stuck keyboard.


I’m sorry that it took so long time. It was really hard problem to solve.

1 Like

The issue appears to be fixed! I have not had it happen at all since the update.

One minor issue introduced by this version: when filename editing begins, the window “appears” to lose focus, though the editing behaves as expected.

Thank you for taking the time to track down and squash this bug!

Awesome news, darwin! (I have the same minor issue as musicman3320)

@musicman3320 Yes, I can confirm the issue with losing main focus when editing. This is a minor visual glitch. I will wait for additional feedback - there may be other things changed/broken due to new focus sharing system I didn’t catch during my testing. Then I will look into it.

Thanks for all your help.

Hi, I use this thread to report another little bug. I’m using the last beta version. I select some objects in a folder and I keep opened the finder window. Then I rename something on the desktop, when I press enter to confirm, the items on the folder unselects themselves.

Regards for your amazing work!

Darwin, since this fix, there are other issues regarding renaming. Currently using 1.6.12 and the following are still present.

  1. The window loses focus when entering edit mode. (You’ve confirmed this above)
  2. While editing a filename, the original filename is shown behind it. Easily reproduce this by editing a long filename and remove some characters
  3. A file/folder name in the list below the entry being edited turns blank. This is often the entry right below but I’ve seen it blank out entries up to 5 lines below. The blanked entry returns unharmed when editing is finished.

2 and 3 can be seen in the included image in Paul’s post “Totalfinder 1.6.12 problems”

1 Like

I’m going to work on this. Hope I will figure out some solution.

Note that latest version of Totalfinder updated last night (1.6.13). However, unfortunately, the same problems remain …

Yes, I didn’t have time to really tackle this problem. It will be harder.

OK thanks Darwin. Doesn’t take away my enjoyment of using the app…hope to see a fix in the future. Cheers

1 Like

Any chance on a fix for this issue yet? It is really bad some days.

Darwin, Any update on this bug? It is getting worse!

Yesterday I tried to rename a file and was unable to do so because when it entered renaming mode, I couldn’t find the filename. This morning I tried another rename and noticed the filename being drawn way outside of the Finder window!!

I moved the Finder window near where it was appearing just for this screenshot but the original location was on the other side of my 27" monitor. If it wasn’t for the cleared Desktop, I might not have noticed it, again.

I’m running TotalFinder 1.6.27 on OS X 10.9.5

I tried to find some solution multiple times. Unfortunately without success :frowning:

Internal Finder implementation of that edit box assumes only single Finder window with focus.