Finder.app is not available any more

Hi,
After a recent update, I noticed that Finder.app is not “available” any more.
I am no longer able to run my large amount of AppleScripts, which got the following error:

  Finder got an error: Application isn’t running. (-600)

And several another Finder extensions such as “Default Folder X” can no longer work with TotalFinder.
In the old versions, Finder AppleScripts, Default Folder X and all other applications working with Finder also works with TotalFinder. But now, all of them are broken.
I am wondering if it is possible to fix such regression. Thanks!

Hi,

I assume you speak about update 1.6.1 under Mavericks.

Can you please check Console.app when you execute the applescript? There could be some additional info. Is Finder process really running at that point?

Thanks for your reply!
I tried executing ps in Terminal, and find Finder.app is running, like this:

% ps aux|grep Finder
jichi            142   0.3  1.3  4274052 106908   ??  R    Thu01PM  13:20.73 /System/Library/CoreServices/Finder.app/Contents/MacOS/Finder
jichi          17263   0.0  0.1  2559560  10028   ??  S    Fri11AM   0:07.43 /Applications/TotalFinder.app/Contents/MacOS/TotalFinder -psn_0_3810210
jichi            196   0.0  0.0  2485352   1480   ??  S    Thu01PM   0:01.19 /Library/ScriptingAdditions/TotalFinder.osax/Contents/Resources/TotalFinder.bundle/Contents/Resources/TotalFinderCrashWatcher.app/Contents/MacOS/TotalFinderCrashWatcher -psn_0_118813
jichi          36362   0.0  0.0  2432768    536 s002  R+    6:37PM   0:00.00 grep --color Finder

However, the AppleScript does not work, like this:

% osascript
tell application "Finder" to empty the trash

29:44: execution error: Finder got an error: Application isn’t running. (-600)

Please open /Applications/Utilities/Console.app and observe error reports there. I hope there will be some additional info about that failed apple event.

Additionally please try to execute the osascript command against basic Finder (use CMD+OPT+ESC to restart into basic Finder.app without TotalFinder)

To me that error does not make sense. It looks like applescript subsystem is unable to deliver apple events to the Finder process.

Hi,
I tried “CMD+OPT+ESC”, and found there were actually TWO finders running at the same time.
After I quit both finder and restart TotalFinder, now all apple scripts work like before.
Thanks for your help!

1 Like

I’m glad you’ve found the problem.