Help! TotalSpaces2 installer failure on Mountain Lion leaves original TotalSpaces non-functional

I just tried to install TotalSpaces2 on a Mountain Lion system. The installation proceeded but failed. According to the Console log TotalSpaces can only be used on a Mavericks system. (Shouldn’t the installer detect that and not attempt installation?) However, version 1.2.11 no longer works correctly. I’ve tried rebooting and trashing the preferences file to no avail.

Help, please!

The installer is supposed to be set to minimum version OSX 10.9. I will check this asap.

Please run the TotalSpaces uninstaller.

Then re-install TotalSpaces.

Where do I find the installer for 1.2.11?

Umm, the link to the uninstaller doesn’t seem to be working.

It’s, not .org.

Oh, so sorry, wrongly typed link. Do you have it ok now?

And the installer for 1.2.11 is here:

Thank you! Thank you! Thank you! Everything is working again. I’m totally lost without TotalSpaces. The hotkeys I use are wired into my brain.