Hiding TotalFinder visor inadvertently shows TotalTerminal visor

If I have both TotalFinder & TotalTerminal, hiding the TotalFinder visor will trigger my TotalTerminal visor to show. This is very clunky and I’m forced to rehide the terminal again.

Video

Steps to Reproduce:

  1. Show TotalFinder Visor
  2. Show TotalTerminal Visor
  3. Hide TotalTerminal Visor
  4. Hide TotalFinder Visor
  5. Results in TotalTerminal Visor showing again without asking it to

Any update / Fix on the way?

This behaviour is by design I believe.

When you hide TotalFinder Visor in step 4. It tries to return focus to previous active app, which is Terminal.app, and that, in effect, triggers auto-sliding of TotalTerminal.

Disable TotalTerminal auto-slide feature in TotalTerminal preferences, look for “Auto-slide when Terminal.app activates”

Great, works!