Hotkeys breaking with multiple displays

issue

#1

Good day

Thank you firstly for a phenomenal product.
The friction from switching spaces and not remembering which space had the app you were working in, is now solved for me.

On that very point, I depend highly on the ‘Hotkeys’ for movement around my OS (CMD + num).
Unfortunately my hotkeys stop working under the following circumstances:
(1) when switching from work office (3 displays) to home (2 displays)
(2) when my laptop goes to sleep and I log back in, I can still see the hotkeys bound (in Layout) but they don’t fire.

Ultimately a restart solves the issue, but this is cumbersome and frustrating when you really pushing to get some work done. I have tried looking for conflicts in Keyboard shortcuts under Mac and there doesn’t seem to be any.
I only recently purchased Totalspaces, but it feels like the problem reared it’s head after the recent update. I say that tentatively.

Thanks!
Dane


#2

We didn’t change anything in the hotkeys in the most recent release. But what I’m wondering is if you are experiencing an internal crash of some sort in TotalSpaces that is causing it to stop working.

Does quitting TotalSpaces and restarting it solve the issue? (or is that what you meant by a restart?)

And it might help me see if there is any underlying problem if you could send me some diagnostics. We have a script for that, follow instructions here: https://gist.github.com/sdsykes/0df8617285b03508e9150448c73a5427/


#3

Thank you kindly.
Yes I meant reloading the application not my OS.

I also emailed through the diagnostics you suggested.

Have a wonderful day further
Dane


#4

Hi Stephen

Did you receive my diagnostics?
The problem seems highly reproducible when using multiple monitors that the hotkeys break. It’s also not inconsistent but guaranteed every time I move from home to office and the displays change. A restart fixes it. Is this expected behaviour? Does it happen to you?

But it’s a restart in the morning, a restart when I get to work, and a restart when I get home. All not too painful, but would be super awesome if it could be resolved in a future release.

Thanks
Dane


#5

Hi, I did look at your diagnostics, but I wasn’t immediately able to figure out what was causing the hotkeys to stop working. I intended to come back to it… sorry for the delay.

The hotkeys should rebind when you change displays, but maybe they aren’t for some reason.

A question: When this happens, can you go to TotalSpaces preferences -> Layout and change the number of Columns (so click + there for instance). Then click - to get back to where you were. (You don’t have to click the Add desktops button.) This should force the hotkeys to rebind. Does it work?


#6

Sadly it does not.
I think I will merrily just restart every time.
Thanks for your assistance. Maybe if more people complain or express a similar problem we can pick it up again.