Losing keyboard/mouse control of windows

I have just upgraded to 1.6 and I have now had several occasions where I lose control (via either keyboard shortcuts or mouse clicks) of a certain Total Finder window. It is hard for me to narrow down when and why this is happening. I usually have multiple TF windows open, each with multiple tabs. I will app-switch back to Finder and try to arrow up/down a file list and it won’t work. If I switch to another finder window, it’s working fine, but if I switch back to the first one, still no dice. Selecting via mouse works fine in that window. Another time, I had the same symptoms, but reversed, where mousing stopped working, but keyboard shortcuts did.

I’m having the same problem. In my case there’s only one window (Visor) with multiple tabs. Not sure wether it also affects mouse controls, since I almost exclusively use the keyboard. I can regain keyboard control by left clicking a selected file in Finder, accessing the renaming mode. After that everything is back to normal. I haven’t been able to reproduce the problem with a defined series of actions, but noticed it’s occurrence is somehow linked to cutting/pasting files.

I’ll try to reproduce it as soon as my TotalFinder is working again.

Pretty sure this bug was introduced 2 updates ago (regular updates, not beta). I’m using a single pane in visor mode with multiple tabs on 10.9.2.

All keyboard input to the current tab fails. When it occurs, opening a new tab and immediately closing restores keyboard input.

It’s highly annoying because it affects normal workflow but it’s difficult to reproduce reliably. Hopefully we will see a fix soon.

I believe I am having this issue as well. It happens intermittently when editing a filename. After editing ends, none of the arrow keys or Finder keyboard shortcuts work. Interestingly enough, TotalFinder specific keyboard shortcuts, such as command-shift-right to switch tabs, still work just fine, but command-O or Enter do not. Clicking on another tab and then back fixes it most of the time, but not always.

This started a month or so ago and happened every so often, but recently it seems to happen every time I edit a filename. Let me know if I can do anything to help diagnose the source, such as sending Console logs or running special debug builds.

Still not fixed. Please fix?

Hi, I discovered a new way how to handle focus between Finder windows in dual mode and main TotalFinder window. This should bring solution to issues you have been experiencing.

More details here:

TotalFinder 1.6.10 should fix all issues with stuck keyboard.


Loss of keyboard functionality still happens with 1.6.16 on my system. I like to view in Browse mode and rapidly use the arrow keys to move up/down, left/right and I still lose that functionality, usually in a window with more than one tab.