[RESOLVED] Mouse actions in tabs work only on very top pixels and not the full button

I love total finder and this is one of my favourite apps I use on a daily basis.
I´ve the latest Total finder version 10.10.4 on OSX 10.10.3 and a strange phenomenon:

The Tap itself, the round red tap close button and the make new tap button work only on most top pixel and not through the whole expected area.

When I like to change the tab, I need to click on a 2-3 pixel narrow area on the top of the tap, but when I click right in the middle of the tap, the mouse is not recognised.

Same with the close button. I would expect, that the button works then I click somewhere on the button, but also here I have to find a small area just on the very top of the button.

Button is not working, but the mouse pointer is on it.

Only on the very top of the button the mouse pointer activates the button.

Please have a look and provide update.

Thank you for reporting. Yes, I understand why it is happening but I should not. This is definitely the toolbar thing introduced in 1.6.24.

It looks like you got TotalFinder into a state when it thinks the mouse is not over tabs. I wonder if this is somehow reproducible. I tested the situation here with 1.6.25 and I was unable to reproduce it.

Is it still an issue when you open a new tab and move mouse out and back over tab again?
Is it still an issue when you open new TotalFinder window?
Is it still an issue when you restart Finder.app + TotalFinder?

Thank you.

Hi, thanks for your quick answer.
Yes, the issue remains on all your cases.
Restart, reboot - nothing helps.

What to do?

A workaround for now is to return to the old method with ugly toolbar.

In Terminal.app execute this command:

defaults write com.binaryage.totalfinder TotalFinderNoFinderWindowClipping -bool yes

Restart Finder.app via CMD+OPT+ESC and launch TotalFinder.app again.

Great, outstanding support!!!

Now it works as expected and the tabs are not ugly.


1 Like

I will investigate this problem tomorrow. I would like to hear from more affected people to pin-point the issue.

Made this account because I was looking for other mentions of this problem; unfortunately I’m having the same issue after installing v1.6.25. The Terminal-command worked perfectly as a workaround.

Working on an iMac, these are the specs:

If you need any more info, I’ll be happy to provide it of course :slight_smile:

Ran into the same problem after updating to 1.6.25. Couldn’t activate or close tabs anymore. Reverted to the last stable release (1.6.17).

In this new build, when I click on the close icon – the x in a circle – on the tab, when i point to the x nothing happens. I have to aim at the top of the circle around the x for the close in order to close a tab.

Running Yosemite 10.10.4 beta.

Ok, I’m back. I have reviewed the code and there was one code path I missed.

You are affected if you are using Visor window (in non-free-form mode). Can you guys confirm this is your situation?

I will release an update .26 on beta channel shortly.

For those who applied the tweak, here is the way how to remove it again:

defaults delete com.binaryage.totalfinder TotalFinderNoFinderWindowClipping

This issue is hopefully resolved in 1.6.26:

Please confirm. Thank you.

I’ll check this evening if it’s resolved here. I was working with the Visor window, so it appears you’ve located the problem :slight_smile:

Confirmed, problem solved! Thanks!

1 Like

I confirm as well.
Now it´s working perfect again.

(Best support ever from you guys, Thanks a lot)

1 Like