Sorting issue

Sorting for size or anything else dosn’t work propper since OS 10.11.

Experiencing the same here

Seems like sorting is correct on start-up or wake-up, but as soon as you try to change sorting by clicking column headings, then the order is random.

And it seems really random: It doesn’t look like files are sorted according to some other column than the clicked

/Karl Erik Jessen

Thanks for reporting. I’m going to investigate it over the weekend.

1 Like

In 1.7.10 sorting still doesn’t work proper when folders on top is enabled.

Yes, sorting is still completely messed up in 1.7.10 on OSX 10.11 with folders on top. (It may be without folders on top, but I only use FOT so have no direct knowledge there).

It is sorted correctly initially upon clicking on a folder, but subsequently clicking on one of the column headers to sort on something else ends up not sorted in any way (appears to be random order, honestly). This is true even in folders that don’t have any sub-folders, i.e. folders with only files in them.

The only want to get it sorted is to click on another folder, then back on the first folder.

(And, to your question about whether it is really worth it to disable part of SIP in El Capitan for TF, folders on top and the split window is TOTALLY worth it. I essentially paid for TF for those two reasons alone; everything else is just gravy.)


Just asking: Is there a chance for a fix about that? If you say, TF is dead I’ll look sadly for a alternative.

I made some promises about this getting fixed, but didn’t get to it yet :frowning:

I’m sorry. Give me few more weeks.

Don’t feel pushed! I’ll be patient :wink:


I am a paying user and love TF :slightly_smiling:

BUT…I also have this issue and it’s really making TF not usable.

Would you fix it soon, please? It was first reported as a bug in October '15 so I guess it’d be fair as a paying user to expect a fix sooner rather than later now after 4 months with no fix?

Thanks :slight_smile:

Hi Rasmus,

I agree this has to be fixed. Unfortunately I tried to fix it multiple times and never found a good solution. My best solution so far seems to work but makes Finder unstable, because I instruct Finder to “rebuild” whole view after clicking on the column header (or changing sort order in another way) Unfortunately that “rebuild” operation can go wrong sometimes if there is some other part of Finder expecting old situation. It seems to be a tricky problem.

Good news!

I have just released a new version on beta channel, which hopefully addresses this issue:

1 Like

Works like a charm, thanks so much! I’m buying another license just for the heck of it to support you guys, this bug has been around for a while and I know it was probably difficult to fix. I know $9 definitely doesn’t cover all the dev time that’s gone into this.

1 Like

Seems to work! Thanks a lot for keeping TF alive!

1 Like

In 1.7.12 sorting still doesn’t work proper. What can I do to fix that?

Hi, can you be more specific what exactly does not work? 10.11, Folders on Top enabled, viewing in column mode? Maybe a screenshot would help. Thanks.


I am experiencing this issue with v1.8.0 and Sierra 10.12.1. I principally have TotalFinder so that I can have CUT and PASTE on files and folders. Hard to believe that the normal Finder only let’s you copy. But being able to sort by Modification Date or Size is equally important, and this is broken when TotalFinder is installed.

Sorry to say, this bug is severe enough to ask for my money back.