Spaces on external monitors are swapped

I’m using the internal display and 2 external monitors. One external monitor is connected via DVI and the second is connected via HDMI.
The setup looks like this:

External 1               External 2

Sometimes after re-connecting the monitors, the Spaces from the external monitors are swapped. So all Spaces from External 1 are now on the right monitor and all Spaces from External 2 are on the left monitor.

I haven’t figured out why and when this happens and nothing helps, not even a reboot.
I have to manually rearrange everything, which - as you can image - is quite annoying.

It sounds very annoying indeed.

OS X does not always remember the spaces setups very well. There are a number of threads about this in the forum here.

You may want to check this post Loosing layout after restart (Yosemite) - it might help.

I can also recommend you try my Display Spaces Manager app - you can find it here:

It can record a spaces configuration (meaning which monitor spaces are on), and will try to move the spaces back to that configuration when you re-activate a configuration.

Let me know if it helps at all.

Thanks Stephen.

I’m using Mavericks, not Yosemite, so I don’t know, if the post you referenced applies to me.

I’ll use the Display Spaces Manager app to save my config and will try to restore it the next time it happens. The strange thing is that this problem only occures sporadically, so I cannot just reproduce it, but have to wait until it happens again. But I’ll let you know the outcome.

It just happened again and I tried to use your DisplaySpacesManager tool to restore my Spaces.
Unfortunately it messed it up even more. I now have 5 on my left external monitor and 7 on the right external monitor and they are all mixed up.

I can’t select the output of your utility, so I took a screenshot.

I have two DDI monitors connected to a new 13" mac pro. After unplugging the monitors the macs’s spaces swapped with that on one of the other monitors

1 Like

@dwdqwde22qdqd as per an earlier post here, you may want to check this post Loosing layout after restart (Yosemite)

It may apply to your situation.

@stephen Did you see my update in comment #4?

Ah sorry for the delay. The utility tried to move the spaces, but failed to do so in some cases.

I’m not sure why that is, but it is a somewhat flawed approach anyway, in that the space you are currently on cannot be moved.

I will look at some small changes to fix that, and I will try to add better logging so I can see better what goes wrong. I’ll try to get a new revision out soon.