System won't stick to "All Spaces"

Under the Apps tab of preferences, I’m able to assign apps to whatever spaces I want, and they all seem to work with “All Spaces” too, except for System, it won’t let me choose All Spaces. I just installed El Capitan (fresh, not an upgrade), and I’m running the latest version of TotalSpaces 2.

Interesting. I have System Preferences set to “All Spaces” myself, so I’m not sure what’s going wrong.

It won’t even let you choose it? When you do, what happens?

Please cause the issue again, then see if there’s more information in the Console:

Also, another thing to try:

  1. Open System Preferences.
  2. Right click on the app icon in the Dock.
  3. Choose “Options > Assign To: All Desktops” from the menu.

Let me know if that works for you.

Yep, that worked, thanks!
Incidentally, the same thing happened for Doesn’t matter, because your workaround works fine. Just to clarify though, when I’m on that preferences page, I see the list of apps on the left with the desktop space on the right (and their dropdowns per each row), every app will let me choose SOME space, but some apps won’t let me choose All spaces (other apps will). So, if I click the dropdown for System or, I click “all spaces,” it just reverts to what it had been and won’t actually select “all spaces”. I can choose any other single space though.

Oh, and there’s nothing in the console when I attempt to select ‘all spaces.’ I just tried it with system preferences app. Since I had done it through the dock (successfully, it even reflected ‘all spaces’ in your app’s preferences), I thought maybe that would allow me to select it now, but it still doesn’t, as soon as I change it from all spaces to something else, and then try to select all spaces again, it won’t let me. Luckily I can just do it through the dock though. Thanks again.

Thanks for all the info, hopefully we can track this bug down.


Please try this version of TotalSpaces:

There were some bugs in the Apps pref pane, this should fix it.