TF 1.6.7 on OS X 10.9.4 - 'Visor' not showing

Continuing the discussion from TF-1.6.6 on 10.9.4: Doesn`t launch:

Version 1.6.7 seems to solve the not starting problem on my installation, BUT
so far I haven’t been able to raise a visor window.

I’m going to Logout and Restart then come back to the forum and report.

After Restart:

  1. Visor still not showing
  2. None of the previously set visor tabs are accessible from links; i.e. in Safari, to show a downloaded file in Finder, click the mag-glass – now nothing happens.
  3. With TF 1.6.7, Trash won’t open a window from the Dock by clicking or by contextual-menu, BUT it does empty by contextual-menu.

So, for the moment, I’ll go back to TF 1.6.2

So, the restart didn’t work BUT…
in TF Preferences->Visor uncheck Free Form Window restores everything, but you lose the free-form-windowing of the Visor.

Found this after many twiddles in the TF-preferences, (uncheck, re-launch, check, then repeat ad nauseam).

I’ve been working on this since 1.6.7 was released because it was a PITA. I’ve gotten so used to having TF present that it was a pain to lose it’s functionality.

Thank you for your detailed reports. I changed bunch of code in Visor and other plugins which should react to preference changes, I overlooked probably some combinations.

Let me review it for next 1.6.8 release. I’m sorry for the troubles.

This is really PITA. I didn’t find anything bad in my code at this point. I tested it on my 10.9.4 system and all worked as expected for me.

Maybe it is time to trash whole and start from scratch.

Please execute these three lines in (copy&paste them one by one):

osascript -e "tell application \"Finder\" to quit
mv ~/Library/Preferences/ ~/Desktop
osascript -e "tell application \"Finder\" to «event BATFinit»"

This will move Finder plist to your Desktop. Finder’s plist contains all Finder settings and TotalFinder’s as well, including TotalFinder’s license info. When you run Finder next time, it should create a new file with default values. TotalFinder will do the same for its own settings.

Please let me know if this helped.

Hi Darwin;

Thanks for the quick help!

I had upgraded to TF1.6.8 just before I read your message.

1- The result: no change from TF1.6.7
2- I then tried to execute the BASH lines -curiously, none of them executed from Terminal
3- I then tried as “sudo” - again, none of them executed.
4- Last, I did it the hard way, followed by Logout/Login

NOW FreeForm works (and everything else) the way it is supposed to…
This was definitely a plist issue.

(Now I just have to track down the Terminal/osax issue :blush: )

Thanks again, (and thanks for TotalFinder and TotalSpaces - great software & great support)

1 Like