Total Finder not running under Yosemite

I am an owner of Total Finder. I run it on 3 Mac, all are updated to the latest version of Yosemity. On 2 machines everything is fine, the icon is visible in the Menu bar and behavior is as usual. On my MacBookAir mid 2012, TotalFinder does not run. I find the icon in the Programm Menu, if I click on it, nothing happens. The icon is not visible in the Menu Bar. I uninstalled Total finder several times and reinstalled the latest version, I also removed the Finder Plist data, before reinstalling.
This is a petty, I dont have a clue, why it is not working anymore. TotalSpaces works flawless on the same machine, but TotalFinder doesn’t work. I run Yosemite on this machine long time, used to install it as Beta User, initially it was working. I can’t recall to having something changed, that might interfere with TotalFinder. This machine has another strange behavior, Safari is running very slow, and often hangs, I usually have to use Firefox or Chrome, which run easy. Maybe this has something to do with it.
Any advice??

Kind regards,