Total Finder version correct or incorrect

Sign pops in and reads; "You have Finder Version 10.6.8
but Totalfinder was properly tested only with finder version range 10.6 -10.6.7
You have probably updated your system and finder version got bumped by Apple developers.
You may expect a new Totalfinder release soon.
CANCEL Launch Totalfinder anyway
so I launched it and works as expected
Question Do I need to downgrade TotalFinder version or stay this way …

I assume you are running OS 10.6.8.

Please install the last supported version of TotalFinder for this system:
http://totalfinder.binaryage.com/snow-leopard