TotalFinder 1.9.1 not running on Sierra 10.12.4

I’m getting the Apple Events error, and the previously posted workaround, (terminal: sudo killall -KILL appleeventsd) isn’t working. I tried deleting the app and reinstalling, but that didn’t help either. I also tried downgrading to 1.9.0 but had the same problem. Have downgraded to 1.8.2, which is working, until there’s a fix.

Maybe you have modified some TotalFinder resources?

TotalFinder 1.9+ newly checks code signatures of all its components. I decided to do that to prevent potential scenario when the SIP-circumventing TotalFinder’s system component would be tricked to attempt to execute some spoofed code.

Please open /Applications/Utilities/, filter the view with “Finder”, force quit via CMD+OPT+ESC and kill via Activity Monitor, then please launch /Applications/ and observe the log. There should be an exact reason what component failed to load due to “corruption”.

I have same issue here, 10.12.4 with TotalFinder 1.9.1.
The console shows

TotalFinder(433) System Policy: deny scripting-addition-send 'BATF'/'init'

multiple times before it shows the error of Apple Events things. And of course, I didn’t modify anything of TotalFinder itself.

6 posts were split to a new topic: How to specify custom sidebar icons?

I solve this problem by removing TotalFinder and reinstall it again.
I think it’s caused by SIP, I thought I disabled it but it didn’t. So the /System/Library/ScriptingAdditions/TotalFinderSIP.osax file can’t be replaced to latest version, that’s the reason.

I have same issue here, 10.12.4 with TotalFinder 1.9.1. I’ve grown weary of dealing with the unstable TotalFinder 1.9.1 and have reverted to TotalFinder 1.8.2.

Some people ran into similar issues by moving /Applications/ to a different place. TotalFinder.osax which is a separate system component which injects TotalFinder code into expects TotalFinder files to be located in /Applications/ This has some technical reasons.

Please refer to this topic for further info how to move your

Just updated to 1.9.3 and still having the same problem. TF won’t launch, giving me the Apple Events error. I have not moved it to another folder or modified any resources. I simply ran the installer. That’s it.

Could you please open, filter all messages with “Finder” keyword and look for any error messages?

Here’s what comes up (the two denials repeat over and over):
default 13:50:06.796256 -0700 TotalFinder requesting injection into[18153]
default 13:50:08.801191 -0700 Finder TotalFinder(18148) System Policy: deny scripting-addition-send ‘BATF’/'init’
default 13:50:12.860899 -0700 Finder TotalFinder(18148) System Policy: deny scripting-addition-send ‘BATF’/'init’
default 13:50:17.059743 -0700 Finder osascript(19487) System Policy: deny scripting-addition-send ‘BATF’/‘init’

Thanks, could you please follow this gist and send me the output?

System Integrity Protection status: enabled.

/Library/ScriptingAdditions/TotalFinder.osax com.binaryage.totalfinder.injector 1.9.3
/System/Library/ScriptingAdditions/TotalFinder.osax com.binaryage.totalfinder.injector 1.8.2
/System/Library/ScriptingAdditions/TotalFinderSIP.osax not present
/Applications/ com.binaryage.totalfinder.agent 1.9.3

Ah! We got it!

/System/Library/ScriptingAdditions/TotalFinder.osax must not exist and /System/Library/ScriptingAdditions/TotalFinderSIP.osax should exist.

I will have to review my code. I’m not sure how you got into this state.

Installer should remove that file when you are in SIP-disabled mode and install TotalFinderSIP.osax instead.

To fix your situation:

  1. disable SIP in recovery OS
  2. boot back into your main system, uninstall TotalFinder, this should remove /System/Library/ScriptingAdditions/TotalFinder.osax, make sure it was the case
  3. install TotalFinder 1.9.3 again from scratch
  4. boot into recovery OS and enable SIP again

Details here:

I’m sorry for this annoyance. I will have to figure out how anyone could get into this state.

It worked! Thank you so much! I can’t live without this app, so I appreciate your patience!
Very best,

1 Like