TotalFinder and Alfred - problem with "reveal in Finder"

Whenever I find a file with Alfred and try to execute the “Reveal in Finder” function (Cmd+Return), TotalFinder opens a “ghost” window in the middle of the screen that is unresponsive and cannot be closed unless TF is restarted or I open a new Finder window. I experienced this problem on TotalFinder 1.6.16 on OS 10.10.

1 Like

I’ve noticed the same behavior, but it happens with any software that has the option to reveal in finder, like image capture, safari downloads and etc… I always get the ghost windows in the middle of the screen.

If I restart finder and disable total finder I can use the reveal in finder normally with the windows appearing in the middle of screen but totally usable and closable.

I’m us gin the lates version of total finder with OSX Mavericks 10.9.5


1 Like

This problem is reported also here Bug in Total Finder Shows Permanent Image On Desktop

I have the same issue, and due to this LONG-STANDING OLD BUG that apparently binaryage refuses to acknowledge and fix, I’m now just using standard finder - and can’t recommend totalfinder anymore.

What is the point in these forums if binaryage ignores them?

1 Like

I too have this issue and have reverted back to using normal Finder recently as it appears to be more evident than in the past.

I used to recommend TF to all my new Mac friends - unfortunately due to this (and other issues that have crept in) I can’t do that any more.

1 Like

I think I have the same problem. Highly frustrating as it stops me doing som many tasks.

“Show in Finder” or “reveal in finder” or other calls from software to Finder often ends up like this. Heres and example from Firefox:

1: I press the magnifying glass on a file…
See the top right corner, under “Download”

2: Then this unresponsive window comes up.
It allows me to open the file, but not much more. And it is unwilling to go away:

On a happier note - Dropbox and Sharefile is partly succesfull in showing files. But showing from Safari or Firefox

Please good, great Mr. Totalfinder-developer help fix this bug! It is very annoying, and has forced me to stop recommending TotalFinder to friends and family!

My setup:
2014 Macbook Pro Retina 15"
OSX Yosemite 10.10.14

I have tested running Total Finder from a vanilla account (no other plugins or software installed) and that seems to work fine.

My startup items:

(PS: Some Images are scaled down a little. You can double the size through zooming in at them.)

The solution from this post solved it for me:

1 Like

I still have this issue with the latest version (1.7.8) of TotalFinder. Why can’t this long-standing bug be fixed?

That solution worked for me as well, and I’m currently using 10.12 (Sierra).