TotalFinder does not launch

I’ve been having this exact problem since yesterday’s update. Even going back to an earlier version didn’t fix the problem. 1.7.3 has fixed it. TotalFinder launched right away without issue.

On OSX 10.10.5 - had issues with finder lag - so I removed ~/Library/Preferences/ TotalFinder crashed, and now won’t startup. Unintalled & reinstalled thinking maybe there was some setting that was a dependency and only written on installation, however TotalFinder still won’t startup.

It generates a system notification that sends me to this thread.

I just updated to 1.7.0 today, didn’t have this problem before, now TotalFinder fails with this bug, and the workaround does not help.

I am running 10.9.5, on a 2011 iMac.

Normally I don’t get to use TotalFinder for long, anyway, it freezes, and I have to start Finder.

Can you open and filter All Messages with “Finder” keyword and look what other error messages are there during TotalFinder launch?

11/25/15 6:09:32.126 AM Finder[17021]: AppleEvents/sandbox: Returning errAEPrivilegeError/-10004 and denying dispatch of event syso/exec from process 'osascript'/0x0-0x20e20e, pid=24082, because it is not entitled to send an AppleEvent to this process.
11/25/15 6:19:32.199 AM Finder[17021]: AppleEvents/sandbox: Returning errAEPrivilegeError/-10004 and denying dispatch of event syso/exec from process 'osascript'/0x0-0x211211, pid=26013, because it is not entitled to send an AppleEvent to this process.
11/24/15 12:20:49.846 PM TotalFinder[3972]: requesting injection into[3903]
11/24/15 12:25:49.839 PM TotalFinder[3972]: too many trials, stopping the timer
11/24/15 12:28:29.252 PM TotalFinder[3972]: requesting injection into[3903]
11/24/15 12:28:53.919 PM WindowServer[153]: disable_update_timeout: UI updates were forcibly disabled by application "Finder" for over 1.00 seconds. Server has re-enabled them.
11/24/15 12:28:57.131 PM[543]: ([3903]) Exited: Terminated: 15
11/24/15 12:28:57.365 PM spindump[16950]: Finder [3903] unable to symbolicate
11/24/15 12:29:01.582 PM Finder[16954]: TotalFinderInjector v1.7.10 received init event
11/24/15 12:29:01.583 PM Finder[16954]: TotalFinderInjector: Installing TotalFinder from /Library/ScriptingAdditions/TotalFinder.osax/Contents/Resources/TotalFinder.bundle
11/24/15 12:29:03.533 PM Finder[16954]: Unable to resolve class TSidebarScrollView
11/24/15 12:29:03.534 PM Finder[16954]: TotalFinder was unable to resolve 1 Finder classes. Please update TotalFinder.
11/24/15 12:29:04.492 PM Finder[16954]: Launching TotalFinderCrashWatcher from '/Library/ScriptingAdditions/TotalFinder.osax/Contents/Resources/TotalFinder.bundle/Contents/Resources/'
11/24/15 12:29:05.063 PM TotalFinderCrashWatcher[16982]: Unable to obtain lock '/Users/v/Library/Application Support/.TotalFinderCrashWatcher.lock' - exiting to prevent multiple CrashWatcher instances

because it is not entitled to send an AppleEvent to this process

For some security reason cannot deliver apple events to your running

This looks like some special setup of your OS. I don’t know how technical your are. Can you please double-check that is present in /Applications of your system and not anywhere else? Can you check that TotalFinder.osax is present in /Library/ScriptingAdditions and not anywhere else?

Can you try to create a new pristine user account on your system, log under it and try launching TotalFinder there?

I have this problem since macOS Sierra.

Me too on one machine, no problems on my MacBook now on macOS Sierra but on my iMac which I just updated TF doesn’t work, tried rebooting the machine and the workaround in Terminal, didn’t fix the problem so far.

Ever since upgrading to Sierra I’m getting the error message “Troubles launching Total Finder - Apple Events cannot be delivered”. The “Read More” button links to this thread.

Here’s a paste of the terminal output and console logs after creating a ~/.debug-totalfinder-injection file, relaunching Finder (force quit isn’t an option anymore), and launching TotalFinder from the terminal:

I experienced the same when upgrading to Siera on a MacMini - simply reinstalling TotalFinder fixed the issue for me.

To get TotalFinder back up and running I had to do the following:

  1. Run the following command in Terminal:
    sudo killall -KILL appleeventsd

  2. Open Activity Monitor and Force-quit any active TotalFinder processes.

  3. Delete TotalFinder from the Applications folder on the system.

  4. Download and reinstall TotalFinder.


I just installed 1.9.1, the version that was supposed to have no problems with SIP, and I am getting this message. I’ve beeen trying everything you guys mentioned here to no avail.

@sambatyon Did you manage to resolve the issue? Maybe shoot me an email to and we can walk through the installation together. I have some diagnostics shell scripts which should give us more info what went wrong.

Hey, thanks @darwin, I figure it out, I had to disable SIP before installing and enable after installing, not enabling SIP before installing. Once I did that all worked again.

1 Like

After upgrading to Majove 10.14.4, I accidentally rejected the AppleEvents permission and ended up in a dead-end.

I’ve followed the instructions as suggested by @darwin, reinstalled TotalFinder several times, disabled/enabled csrutils before the installation, deleted all the files related to TotalFinder, etc. However, none of the variations triggered the access permission dialog box again.

$ tccutil reset AppleEvents

The command above resets the authorization access which fixed the problem.


After upgrading to Big Sur today, I came across the same issue. sudo killall -KILL appleeventsd does not solve the issue.

what to do in Big Sur ? thanks

Please make sure you have installed the latest beta and follow this article:

Apologies to ressurecting this thread again. I have some new info for Mojave and Big Sur.

I have introduced a better/simplified way how to inject code into Finder in TotalFinder 1.13.6, but that solution is not perfect and caused issues for some. Thanks to people requesting support and searching for solutions I gained more understanding thanks to these articles[1][2]. Hopefully this will be resolved in 1.13.7.

Short version: TotalFinder cannot deliver apple events because you didn’t grant it first time and system “remembers it”.

Long story:
When TotalFinder wants to inject code into Finder, it sends a special apple event from to System should prompt user for permission first time this happens. Most people grant this permission and live happily. Those who don’t and dismiss the dialog prompt have to deal with consequences. Because system does not give TotalFinder a second chance to prompt user for permissions. It does not deliver the events and from TotalFinder’s perspective it is not clear why. Even reinstallation does not help because the permission stays “not granted”.

Sometimes it is possible to manage the permission from via System Preferences > Security & Privacy > Privacy > Automation, but it is not always visible there.

Sometimes it is also possible to reset automation permissions via, but this does not always work:

tccutil reset AppleEvents

I have just tested under Big Sur and there this works predictably as expected. Under Mojave this seems to be pretty broken. I could use old TotalFinder injection code under Mojave and new code under Big Sur, but I’d like to find a way how to make this work on both systems. To be continued.

I wrote a support article at