TotalFinder hangs (or crashes) Finder at startup

This problem is literally driving me CRAZY. Can we please gets a walk-through of how to solve the issue? My FINDER has been screwed up for nearly two weeks now and its hard to even do work.

??? Im imagining that if there are this many posts on this problem that there are exponentially more people effected by this.

Its seems to be the TotalFinderCrashWatcher that is having problems.

I’m going to release new TotlaFinder 1.6.2 on beta channel this weekend. I hope to solve it, but still without reproducible case, it is just guesswork.

I’ll video share my screen with you… tell me what you need to see. I’ve uninstalled TotalFinder and the problem still remains. Seems like TotalFinder screwed up regular finder some how.

TotalFinder 1.6.2 beta is out:

I did review of the code and made whole process of restoring previous tabs more reliable (changed timing and sequencing of individual operations). But I still don’t know if this could potentially fix the issue.

Please test and report here. Thank you.

I was having these issues (maybe not as severe as others), but now TotalFinder is very snappy on launch. Thank you!

1 Like

1.6.2 still didn’t resolve the problem for me. To be clear, I have uninstalled any prior version and installed 1.6.2 and that didn’t help. I have also uninstalled 1.6.2 and tried reinstalling it from scratch that didn’t help either.

This is what I am see occur while monitoring with Activity Monitor. Once Totalfinder starts up it causes Finder to start using 99.8% to 100% of the CPU and the amount of memory starts growing, it also shows Finder as Not Responding. I let it run for about 10 minutes to see if it would shake out and come back down in CPU and Memory and it didn’t. However, finder did not report as Not Responding any longer. But to be clear it was still using 100% of CPU. I had to right click on the Finder/TotalFinder icon on the dock to relaunch Finder. This caused CPU and Memory to drop to normal again. I am again running 10.9.4. For me this problem started with 10.9.4 and I was running TotalFinder 1.6. Something about Finder has changed as I have never had any issues with TotalFinder updates in the past. I am wondering if something meant for Yosemite has found it’s way into TotalFinder for Mavericks? Just throwing that out there. Very frustrating problem though, I miss using TotalFinder, it made Finder what it should be.

Hope this info is helpful in some way.


I did more testing on my system and when the Tabs Plugin is enabled Finder essentially crashes. If I disable the Tabs Plugin then Finder and TotalFinder work. I am running 1.6.2. I hope this get resolved soon, not being able to run the dual mode takes away one of the biggest benefits of using TotalFinder. Visor feature is really nice too.

Are others still having a problem with TotalFinder? Seems that this issues has been dropped as I see no more comments about it.


@Erick_Gabriel could you please go and test all beta versions. You could use bisecting method to find the first one which started this behaviour.

It should be somewhere after 1.5.20 (I believe this version does not have this issue)

Also you could send me your ~/Library/Preferences/ to

Thank you.

I didn’t have a lot of time to do all of the installs, but I tested the following
1.5.20 (I jumped to this one since you thought it might just work. Due to the time I had.)

I was installing them in reverse and all would crash Finder once I enabled Tabs Plugin. 1.5.20 presented the strangest behavior when I enabled tabs and restarted Finder. It never displayed just the Finder CPU utilization behavior like the others did. It showed multiple tabs, almost like a Finder window on top of a Finder window. But all of them caused Finder in Activity Monitor to show 100% CPU Utilization. But it was 1.5.20, tested thus far, that seems like it was trying to run multiple Finders at the same time. Very odd behavior, the window on top was flashing or flickering over and over. I will try the others tomorrow as I have time. Hoping this might help you for the time being.

I am thinking this problem has something to do with 10.9.4. May be Apple changed the way Tabs work in Finder for this version? You might have to investigate that with them. Tomorrow I will try other versions in the list and see what happens.


I have now tested these versions.

All cause Finder to crash just like the others do. I will test more later today.


@Erick_Gabriel thank you

I might be really related to 10.9.4 update. Please also check items in your sidebar. Don’t you have any special items there? Some link to a server or remote location?

Other than the typical sidebar Favorite items, such as, Air Drop, All My Files, Applications, Desktop and so on. In Devices I have my Time Machine mount to USB Drive. For Shared: I have my USB drive on my Airport Extreme and my HP multi function Printer a HP Officejet Pro 8500.

Screen shot to show you directly.


defaults write TotalFinderDontRestoreTabsState -bool yes

I can confirm this on multiple computers at our studio. Without changing anything else, this fixed the hangup probme for me and my team. Computers were upgraded to 10.9.4 and TotalFinder 1.6.2 and TotalFinder no longer would launch, just hang. Rolling back to 1.6 didn’t fix it either. But after entering this single line in Terminal on affected machines, problem solved. Thanks darwin!!

Excellent! Sev’s method worked. It has solved the problem. TotalFinder works like normal again.

Thank you!

Worked for me as well!

As of yesterday it stopped loading entirely on my system. I have yet to see stable behavior in Yosemite public beta. When it was working, my finder windows would change size when opening a second tab. Now it will not load at all; I get no error messages, just no response.