TotalFinder is Possessed

TotalFinder seems like a decent enough program, but recently it has started doing something truly erratic. First, when I start up Finder (with the TotalFinder running) it takes a long time for it to open up a window (1 or 2 minutes): this isn’t totally shocking since running TotalFinder seems to slow down finder in general. But then instead of opening a window it begins to open multiple windows… hundreds of them, until it finally just crashes the whole system. Since updating to the latest version of Mavericks, it does this every time. If I open up Applications and run TotalFinder, it will go straight into this cycle leading to a crash.

No idea what is going on, or why it started freaking out like this.

What version of TF and Mac OS X are you running? By “latest version”, do you mean 10.9.3 ?
What other troubleshooting have you tried?
Have you tried uninstalling and reinstalling TF?

Yes, I meant 10.9.3.

Latest available versions of Mavericks and TotalFinder available to the public at the time of writing the comment.

Yes, I tried reinstalling TotalFinder, but it doesn’t help. Whatever went wrong with TF, I can’t use it any more on this system.

Please let’s continue in this thread:

I have some news for you.