TotalFinder Yosemite status

Please try to quit Finder from

osascript -e "tell application \"Finder\" to quit"

This is a way how to quit Finder process without immediate Finder restart. Then delete (or move out) all files using command-line:

mkdir ~/finder-plist-backup && mv ~/Library/Preferences/* ~/finder-plist-backup

Then start again and launch

Thanks Darwin, that solved the issue, thanks a bunch! :slight_smile:

1 Like

I’m having problems with crashing too. I can no longer launch totalfinder without it crashing unless all the plugins are disabled as described in the totalFinder crashing thread. I tried disabling all of the plugins and it launched then, but I can’t use any of the functionality in that situation.

I don’t have a ton of time at the moment to diagnose or fix it myself, are there any quick fixes like uninstalling and reinstalling? I’m on 10.10 Yosemite.

Do you have any Finder crash reports in -> User Diagnostic Reports -> Finder_Something?

Please send one or two to Thank you.

Crash was probably the wrong word, It seems to lock up and take 100% of a single core. Thus it is probably unresponsive but hasn’t crashed.

Please try this:

btw. the bounty for finding root cause of the problem is still available, full thread here:

I didn’t have problems with visor after upgrading os; i didn’t have to unflag and flag visor checkbox, but I did it anyway, just to test if it solve my problem: performance.
Visor opening became sooo slow, it is no more fluid as it has always been. It draw the frame of finder and then render the inner content. If I have several tabs, it is definitely annoying. Maybe the dropbox update has get things worst since I didn’t notice this problem the first day I upgraded to Yosemite.
I have a new Mac Book Pro.

1.6.15 fixed this, all working now

I too have this issue, since upgrade to Yosemite 10.10 I am unable to open total finder and i MISS it

Hi everyone ! My TotalFinder doesn’t launch at boot since I upgraded to Yosemite… :\ I’ve already checked and it is listed in the Login Items… Can somebody help me?

All of sudden it seems like that when opening finder it goes to regular Mac finder but clicking on a drive icon it opens total finder proper…
I am on Yosmite and TF1.6.17

I have TotalFinder 1.6.17, and I can’t have it work anymore. I’m on a Mac Pro with Yosemite, and all I get is what you see on the screenshot :Écran.png

I’ve tried to uninstall and reinstall it without success. This the url for the log

Best regards

+1, I would like that feature too.

Adding myself to the queue of users experiencing issues with Yosemite on pretty much all the basic features. TotalFinder doesn’t seem to work consistently, opening new windows with the base Finder and not as tabs at random, sometimes conflicting with the existing tabbing system, crashing from time to time, not responding when using the CMD+Enter trigger from spotlight.
Thanks for the great app so far, but please fix this situation which is really becoming a deal breaker.

+1. I’m experiencing the same behavior ( TF 1.6.17, Yosemite 10.10.1).

My exact experience also.

This is the first problem I’ve had with Yosemite and TotalFinder. Tonight when I launched a new finder window, I just got the “All My Files” pane with nothing else. View Toolbar wouldn’t work, View Sidebar was gray. I was able to get my normal window by selecting “GO -> Applications”, which seemed to invoke the correct finder view.

However, any new “New Finder Window” selections were launching a new, stripped down “All My Files”, instead of attaching to the other finder window. Then, for no rhyme or reason, it started working again as normal.

Total Finder died on me today. It has been fine on Yosemite for weeks but not today. I dragged a file from Mail into a File uploader on a web page, then I opened Total Finder to drag that same file into a folder. I hit cmd+u to get the mirrored-panel tab and it crashed. Now everytime I hit cmd+u Total Finder crashes and I get normal Finder instead.

Tried restarting. No help. Don’t know if it’s related but I ran Yosemite Cache Cleaner (on light setting) before all this happened.

I figured out what was causing the issue!!

It only crashes if View > Hide Toolbar is selected. As soon as I un-hid the Toolbar Total finder started working properly again. Before that it was like I was getting an empty TotalFinder window with a normal finder window opened over that and then it would crash.

Solved the problems with TotalfFinder crashing finder and pinwheels… simply go to users and groups in preferences and start a new user… delete the old one and your problems are solved… yes you will have to do a new set up for your system tweeks… but i have tried every fix mentioned and all of them failed. After doing the new user i have splendid speed in my computer back… no beach balls (pinwheels) and instant shut downs and reboots. Its now a pleasure to work on my computer again…