TotalSpaces slow to display overview grid

First of all, thanks for TotalSpaces — it’s great.

Recently, TotalSpaces is often slow to display the overview grid. I think I noticed this after I upgraded to Mountain Lion, but it’s possible that it happened when I upgraded to TotalSpaces 1.2.9.

Some details:

  • This slowness happens whenever I have around six or more browser windows open.
  • It can take upwards of several seconds to display the overview grid.
  • I get the same with Chrome, Firefox and Safari.
  • Quitting the browser returns things to being near-instantaneous.
  • Re-opening the browser and restoring the previously-open windows leads to the slowness.
  • Initially things are just slow, but after a period of time (opening and closing browser tabs and windows) things can get unbearably slow — 10 or 15 seconds or more.
  • The more windows, the slower things are.
  • There’s a similar but far less pronounced effect when I have multiple windows open in TextMate.

If there’s anything else I could try out to give you clues as to what’s going on I’d be happy to. Perhaps it would be worth trying an older version of TotalSpaces.

Something else:

The above is with OS X 10.8.5. When I was briefly on OS X 10.8.4 the overview grid took even longer to display.

We didn’t really do anything that would make it slower.

I’ve always been concerned by the performance of the overview grid - it’s actually very heavy on the graphics processor to display all the windows. But in most cases it does perform ok, but it is better with recent hardware.

Setting the “Backgrounds in the overview grid” setting to Lo res/Blurred may help.

What kind of mac are you running on?

Thanks for the reply.

I’ve had more of a play and I’ve discovered something interesting: if I /disable/ hardware acceleration things are much, much faster. (I’ve tried that in both Chrome and Firefox.)

It’s not only me who has a problem with hardware acceleration slowing things down; see for example

To answer your questions:

My Mac is a Retina, 15-inch, Early 2013 with:

  • 2.4 GHz Intel Core i7
  • 8 GB 1600 MHz DDR3
  • NVIDIA GeForce GT 650M 1024 MB

I have “Backgrounds in the overview grid” set to “None (fastest)”.

In case I wasn’t clear, disabling hardware acceleration seems to be a solution to my problem. I’ll reply again if that turns out not to be the case

Thanks. So it appears that the way that the browsers use hardware acceleration affects how the mirrored windows in the overview grid. That’s good to know.

The exact reason is something deep in quartz and the way the browsers interact with it.

I’ve just tested about 20 browser windows showing different content (including flash & video) on a basic 2012 MacBookAir running Mavericks, and there is no appreciable slowdown. If you do upgrade when Mavericks comes out I’d be interested to hear if the situation improves.


I’ve made a note to reply again when I upgrade to Mavericks.

FWIW… I’m not sure if the hardware acceleration affects only the overview grid (but maybe you weren’t suggesting that), or whether all windows are slower but it only becomes noticeable when rendering many windows.

Well my reasoning about the hardware acceleration is that the idea of it is to do more work in the GPU.

I was suggesting that in the particular case of the overview grid, we need to be able to show mirrors of all the windows, and it may be that some additional processing or moving data around is needed for this to work if the windows are using this kind of technique.

This is speculation - I do not know the exact details - the windowing system does normally try to keep the window contents represented in the GPU for speed, so it’s not clear why there should be a difference with the hardware acceleration setting on.

I’ve definitely noticed the slow overview when I have a lot of browser windows. Reducing the number does help speed it back up. I haven’t played around with the hardware acceleration settings (will experiment).

Interesting to know the background.


I said I’d let you know what happened…

All is ok now that I’ve upgraded to Mavericks and TotalSpaces2.



  • Stephen

Three years (…) later I was experiencing a noticeable delay for the overview grip to appear in a brand new MBP 15 touch bar running 10.12.2 Sierra. I red the messages in the topic and followed the tip to deactivate hw acceleration. In my case, I have always open several windows of safari and chrome. I tried first in chrome and the delay disappeared.
Thank you very much for the old but useful tips.