TotalSpaces thinks my user has 16 spaces, not 6

TotalSpaces starts up fine, but my user can’t see any workspaces, nor can he add or delete workspaces

preferences claims he has 16 spaces, so he can’t add any.
it looks like he can delete spaces until he tries to commit the change…

Same here – just installed the 2.4.6 update, and it quits and relaunches my dock/refreshes my desktop pictures as expected, but my keyboard shortcuts no longer work. The preferences show an empty grid, for which it reports I’ll need (and supposedly already have) 16 desktops. I’ve tried quitting and relaunching and logging out and back in, no luck.

For the record, the actual spaces still exist and in the original layout – I can reach them by dragging windows to screen edges or by using the dock to access open app windows.

Which OS versions?

Same problem here. I’m using 10.10.5.

I also tried replacing the binary with 2.4.5 but this didn’t help.

OS version: 10.11.6

Same here. OS X 10.10.5. Now it is showing that I need 1 desktop and have 0 but the Rows/Columns buttons don’t do anything and clicking “Add desktops” shows the warning about 16 desktops, max.

“Overview Grid” in the menu does nothing and I get no overlay; sliding animation works, though.

I am having the same problem (os version 10.10.3).

I tried deleting TotalSpaces2 completely and installing a previous version (2.3.9), but the same problems persist :

  • Menu bar icon shows no numbers.
  • Overview Grid - does nothing.
  • Keyboard Shortcuts for Overview Grid & Exposé do not work.

2.4.6 appears to have changed some files somewhere which have rendered previous versions inoperable as well.

Update…I found this thread (TotalSpaces2 status under macOS 10.12 (Sierra)) and found out that I had two separate instances of TotalSpaces2 installed - one in Applications, and one in Applications/eviware. I deleted them both, along with /Library/ScriptingAdditions/TotalSpaces.osax, then reinstalled v2.3.9.

I’m happy to report that everything is working fine again :slight_smile: .

same sort of issue here, Mac OS X 10.10.5 Yosemite.

anyone have a binaryage URL for downloading TS 2.3.9 again?
edit: here it is…

Had the same problem using MacOS 10.10.5.
I reinstalled TS 2 v2.3.11.
I didn’t have the Applications/eviware/totalspaces2 to delete.
But I deleted /Library/ScriptingAdditions/TotalSpaces.osax.
Quit and restarted TS 2.
It works now.

1 Like

Pretty much all the same problem here as described above, running 10.9.5. The pop-up 2.4.6 update wouldn’t work, shows an empty grid, but says I will need 16 desktops. Hotkeys don’t work, number not shown, etc. Found no way to configure it properly. After some trial and error I uninstalled (using provided uninstaller) and put back 2.3.11. Now this seems to work.

OK - same here. Running 10.10.5 on two different computers (iMac Retina Mid 2015 and MacBook Pro Retina Mid 2015) and I have the same problem. I’ve tried downgrading to 2.3.9 and also removing and re-installing with both 2.3.9 and 2.4.6.

FWIW, I quite literally have not upgraded to 10.11 and later because of TotalSpaces. I feel crippled when this isn’t working for me and didn’t want to move to an OS that only had partial support for it. Maybe now I can finally let it be and do it?

Update. I did a complete uninstall with the installer in the 2.3.9 dmg and then re-installed 2.3.9 and now it’s working again. Most of my settings were preserved, so I’m good for now. Something’s seriously borked in the 2.4 version

Same problems under OS-X 10.9.5.

I’m 10.9.5. Tried a soft downgrade (tossing preferences and replacing the app with v2.3.11) which accomplished nothing but wiping my settings. Restoring the preferences, oddly, did not restore all of my settings, maybe because now there were no spaces to match the settings to. I’ll try the full 2.3.9 uninstaller next and see if that works.

Sorry, bad release today. 2.4.6 should work for 10.11 and 10.12, but needs some work on 10.10 and 10.9. In the meantime, to go back to the previous version:

  1. Quit TotalSpaces.
  2. In the Finder menu, choose Go > Go to Folder… (⇧⌘G)
  3. Enter /Library/ScriptingAdditions and click Go.
  4. Drag TotalSpaces.osax to the Trash (you will be asked to authenticate).
  5. Download and re-install version 2.3.11 from here:

I tried the above and it didn’t work for me, but a full uninstall using the uninstaller included with 2.3.11 did – and upon reinstalling, my settings came back.