TotalSpaces2 asking to register on every launch

I purchased a license for TotalSpaces2 several years ago, and am running 2.3.6 now. Since I installed El Capitan, it has been asking me to register on every launch. I close the registration screen and TotalSpaces works.

Is there a way to stop the registration screen from launching on every start of TotalSpaces2?


Sorry this is a bug. Please use this version:


Thank you for your fast and terrific support on this issue!

TotalSpaces2 is working correctly again, and, as always, TotalSpaces2 is one of my favorite apps of all time!

Thank you,

Hi @stephen, I’m having the same problem.

For quite a while now, the initial start up of TotalSpaces would open the registration window (saying that my trial period had finished), but I when go through the steps to re-register, my license is already there and I just have to “accept” and close the window, then TS works fine.

However, today had a different result; the reg window now says that my license is invalid. I have not changed anything on my end.

Seeing your post here from Nov. 2015, it suggests to use v2.3.8; I am on v2.3.9. Before I install v2.3.8, I want to make sure that there isn’t a different solution or a newer version for me to use first.

Please let me know, thanks!

v2.3.9 should contain the fix for the issue discussed here, so you don’t need to downgrade.

If the reg window says your license is invalid, that does point to the license info having some typo in it, but it’s strange if you haven’t changed anything. I was just able to check your license on my machine, and it looks ok from here.

Please a) check that the license info is correct (paste it in from your license email, take care to use the TotalSpaces2 license).
b) If that doesn’t work, you might try uninstalling / reinstalling totalspaces2. If there was some problem with the code signature, then a re-installation should sort it out.

The uninstaller can be found in the v2.3.9 DMG you download from the our website.

@stephen, the uninstall/reinstall worked. thanks for your help!

@stephen alright, well the uninstall/reinstall temporarily worked. TotalSpaces is now asking me to register again, and it’s exactly the same as I wrote above (the license is there, but it says that it’s invalid). Doing another uninstall/reinstall works, but only temporarily. Is there something that’s not getting cleaned out during the uninstall that could be causing this? Is there a log or something that I could provide to help troubleshoot this? Please let me know, thanks!

Sorry for the trouble. Please send us an email to so we can give you something to try.