TotalSpaces2 disables "Show Desktop" gesture in Sierra


#1

In Sierra TotalSpaces2 disables the Mac’s “Show Desktop” gesture (“Spread with thumb and three fingers”) when the TotalSpaces2 preference “Swipe to change space” is set to 4 fingers. Perhaps because they both use 4 fingers?

This did not happen under El Capitan. Why under Sierra? Or did it start with the last update?


#2

I think it was a consequence of the changes made to handle swiping required for Sierra.

I’m sorry I’m not sure this is going to be easy to fix, but I’ll check it.

(I use a hotcorner for Show Desktop but I do understand it’s not to everyone’s taste.)


#3

Thanks, Stephen. I also set a hotcorner for this.


#4

I really need the “show desktop” gesture functionality to come back. Hot corners on a 27" screen are bit awkward to say the least…


#5

Anything?


#6

Hi really sorry I don’t have a solution for this at the moment. The problem is that when 4 fingers are on the touchpad then TotalSpaces must assume that there might be a 4 fingered swipe, otherwise a system controller gesture could activate at the same time as the TotalSpaces gesture.

It would be nice if we could find a way to only disable the system swipe gestures, but I don’t see a way to do it.


#7

Maybe I am missing something here, but if I want to see the desktop all I need to do is press the F11 key on the keyboard.