TotalSpaces2 status under OS X 10.11 (El Capitan)

Maybe I missed it, but does anyone running an external monitor with a MPB loose access to that monitor once you make the command line change for TS in El Cap? Once I changed back, I once again had a live screen on my external monitor. I run 3x3 on both the MBP and SyncMaster.

Stephen - I took a photo (sorry - it’s a tad blurry but still readable) of the kernel panic screen in the hopes that you might derive something from it (at a minimum, perhaps enough to tell me if there is some 3rd party app or something that might be contributing here).

Let me know if this helps on the kernel panics…


@EbE404 can you tell me how you went about doing the clean install and perhaps more important, what are all the things I will need to reinstall/redo if I do this? (clean installs under Windows are a nightmare - hoping it’s not the same "start from scratch sort of thing with reinstalling all of your apps, etc).

Thanks in advance,

FIXED!!! I FIGURED IT OUT! So the Kernel Panic in my case was being caused by the NetGear Control Center app which came with my router to allow sharing of printer connected to the router via USB. Uninstalling Control Center and then rebooting allowed me to disable SIP and NOT get the panic!

I’m going to proceed with TS2 install now. I expect all will be well in my world once again.

@stephen: HUGE KUDOS on TS2 in general and your work figuring out how to get it going under El Cap. I have really liked the app but didn’t realize just HOW VALUABLE it is to me until I lost it. I have about 5 different monitor configurations I end up with between working from home, going into the office, and a couple other common destinations and not having TS2 really messed up my productivity having to reorganize my spaces and such every time I moved. I absolutely LOVE TS2…

1 Like

Outstanding and thanks for posting the solution!

Let me start by saying just how much I love TotalSpaces - I’ve been using it for years and it’s one of my favourite OS X utilities. Kudos to all involved!

Now, on to my issue… I’ve not had any problems with TotalSpaces2 2.3.6 under El Capitan (fresh installation of 10.11 and then Migration Assistant to copy data - SIP enabled, except for debugging attachment), except for one thing - my registration data doesn’t seem to work. Every time I start TotalSpaces2, I get a message to state that the trial period has expired and that I must register. Hitting the Registration button shows my name and serial number and hitting Register seem to work, until I start the app again. Then I get the message to say the trial period has expired, etc.

Any ideas? Has anyone else seen this?

Update: I’ve just spotted this thread. Whoops! That fixes the issue.

Hi, yes, there will be a new release with this fixed soon. It’s due to a dumb mistake that is sensitive to the fact that you have a space somewhere in the path to TotalSpaces2.

Here is the fixed version:

(Update: Okay, good it’s fixed with this update!)

Thanks for the quick response. Indeed. I do have TotalSpace2 in a directory with a space in the name. That updated version resolves the issue :smile:

i downloaded this update and am still getting the SIP notice

This version doesn’t change that - alas no version of TotalSpaces2 can run with SIP fully turned on - see here:

I just updated to El Capitan yesterday(10/17/2015).

I got TotalSpaces2 to work on my Mac Pro after disabling SIP for only TotalSpaces2 albeit it works somewhat differently than before. I have to use my mouse wheel click to get the spaces option to come up which are at the top of the screen now.

However, I have been unable to get TotalSpaces2 to work on my MacBook Pro at all!
I ran Terminal and entered the text code to no avail just as I did on my Mac Pro.

I read this has to be done now in Recovery Mode?
How do I initiate recovery mode?

Reboot while holding down CMD+R.

Hi, have read your instructions on how to get TotalSpaces2 running in El Cap and it worked fine -
but I am wondering what the terminal command would be to turn SIP back on if I wanted to do that in future.

Go back to terminal in Recovery and use “csrutil enable”, then reboot.

Stephen - given the high level of active development of TS2 right now (with all the OS X changes, etc), is there some easy way to be notified when a new build is ready for install? I’m on 2.3.8 now which seems to be the latest, but I’d like to stay current and am looking for some way to auto-check for new versions (no more than weekly is sufficient)

As long as you keep “Include pre-releases” ticked, that should do it, although sometimes I do release versions outside of that to address specific problems or to investigate issues due to questions in the forums.

Ok. I do have that ticked and for some reason, it did not pick up the update from 2.3.6 to 2.3.8. Not a big deal, but I’ll keep an eye on it and let you know if it repeats.

Want to compliment you again Stephen - your support of this product is stellar - most definitely role-model caliber. On top of that, the product itself just keeps getting better and better. I just discovered the new capability that DisplaySpacesMgr has to copy the app assignments along with the desktops and I’m making heavy use of that - outstanding feature, perhaps one of my favorites. Love the delete button it DSM also.

Quick question: is there an easy way to have the window size and position recorded and restored with DisplaySpacesManager? The idea would be that not only does DSM know which desktops to put the apps on, but also remembers how those windows are arranged and sized and puts them to that arrangement as well.

Keep up the fantastic work Stephen!

Yes, the 2.3.8 was one of the releases I did just to fix a specific minor problem for a few people.

Thanks for your kind comments!

Window positioning - it’s something that could be attempted. The only issue is: Can we identify the windows correctly? I think the main thing we know is the title of the window, which in the case of safari or document based apps (or apps such as Terminal) will change depending on what document is open.

For many cases - e.g. Calendar, Slack, Console and so on there’s going to be no problem. It might be worth trying.

I just installed El Capitan. TS didn’t work at all on first boot. I used your guide to disable the debug for SIP, then installed 2.3.8. Now it runs, but shows nothing for layout and the swipe-between-desktops function doesn’t work.

That’s all I really use it for-- disabling animations like the user above. Do I have to disable all of SIP?

EDIT-- nevermind. Uninstalled and reinstalled. Works fine now. Thanks.

Hey! I was browsing the website yesterday and came across some information you guys published on how to disable SIP for just total spaces 2. I was going to purchase total spaces 2 today, but I can’t find those instructions anywhere anymore, have I gone insane or did you guys remove those instructions for particular reasons?