[Update Discussion] TotalFinder 1.14.2 for Apple Silicon and Intel

Another day, another (personal?) problem. Context menus. The Cut/Copy commands displayed on the Context menus one time and then disappeared. I’m going to uninstall and reinstall and see if that clears the problem. Right now, the Context menu is about 1/3 normal size with the Copy command at the very bottom and no resemblance to the TF menu at all (or for that matter, the standard MacOS menu either).

1 Like

@Ken This is a known issue with macOS 13. The “Cut/Copy/Paste” buttons that TotalFinder adds to the right-click context menu will not work correctly until TotalFinder is properly updated for macOS 13.

Thanks for letting me know. I was getting ready to uninstall and reinstall (nice thing about testing, nobody gets upset when you blow everything away and start over). I’m looking forward to the updated version when it arrives.

-ken

1 Like

Hi @akemin_dayo thanks for everything you are doing, we and binaryage guys are really lucky to have you.

I’m using the first public beta of MacOS 13 on a mbp14, I followed any suggestion you wrote in this thread (and I was using TF on BigSur without any problem) but anything I can see is a window with a “read only” contextual menu and noone TotalFinder feature working… I know you are still working on Ventura but I can’t figure out why somebody can run it but not myself.

I disabled debug, sf and nvram (tested with status), tried sudo nvram boot-args="-arm64e_preview_abi" also the suggestion here, and I see TF in privacy/automation. I can open TF preferences but disabling any setting helps, enabling color labels causes a crash and I can only solve it disabling color labels from terminal.

1 Like

Hi All, the updated TotalFinder has been working perfectly for me on Monterey 12.4 on my 16" M1 thanks to @akemin_dayo. Apple now wants me to update to 12.5. Has anyone had any experiences with 12.5? I’m nervous about updating. I don’t want to lose my Colorful SideBar!!!
thanks…for any feedback in advance

1 Like

Is there a way to submit a crash report when TotalFinder crashes or causes the Finder to crash?

1 Like

@Sames TotalFinder 1.14.2 works with macOS 12.5 (21G72)!

I do try to test TotalFinder with each developer seed beta version of macOS released by Apple on a test machine I have just to see if there were any breaking changes. (There generally aren’t any changes like that made this late towards the end of a macOS version’s lifecycle, though.)

One thing of note that I noticed during my macOS 12.5 testing cycle is that… Apple actually accidentally broke AppleScript as a whole in one specific beta version of macOS 12.5 — specifically developer seed beta 5 21G5063a.

This caused… many things, including TotalFinder, to stop working completely. It also made me question my sanity for a good while trying to understand the bizarre error I was suddenly getting (since 12.5b1〜12.5b4 all worked perfectly), until I realised that AppleScript as a whole was broken. ;​P Luckily for everyone, Apple did promptly fix that issue in the very next developer build.


@strafer If you run the included TotalFinder diagnostics script at /Applications/TotalFinder.app/Contents/Resources/diagnose-totalfinder.sh in a Terminal session, it will generate a totalfinder-diagnostics.tar.gz file on your Desktop that includes (among other things) any recent Finder crash logs that you can send to me via email.

It would be helpful if you could give a description of what you were doing (or trying to do) before Finder crashed, too.


@eBara TotalFinder 1.14.2 has known compatibility issues with macOS 13, including the crashing when enabling coloured labels (due to Apple renaming some classes as they… often do).

The only suggestion I really have regarding your “no TotalFinder features are working” issue is to completely reset your TotalFinder preferences.

You can do this by opening the TotalFinder preferences, going to About, and clicking on the “Reset TotalFinder to defaults” button.

Regarding the -arm64e_preview_abi boot-arg: I think I know why it suddenly became required as of macOS 13 — I should be able to address that in future TotalFinder versions, if all goes well.

1 Like

Thank you Karen, i tried it but it still not working, neither cmd+x (for me, the most important feature… Is it possible to detach this feature from TF and make an independent app that does only this? :sweat_smile:). The app opens and runs, no problem entering the preferences, but no feature seems to work. Pretty unlucky :disappointed:

Hi, no problems here with 12.5. The colourful sidebar is my main concern, too.