[Update Discussion] TotalFinder 1.14.3 for Apple Silicon and Intel

@Nurb_2Kea Did you terminate TF? And don’t enable coloured labels in the settings. If you did so, remove the settings file /Library/Preferences/com.binaryage.totalfinder.plist and try again.

Thanks for the update…
On an Intel iMac running 13.0, I can’t get XtraFinder to work. I can’t run the beta. But I’ll be sure to check when 13.1 public is released. I do like TF better; it does a much better job with the readability of colored labels.

Even if you don’t enable colored labels after installing Ventura, it will pick up the colored labels option in prefs from the previous install. If you had TF already installed and working, you will very likely need to trash the plist file to get it working again (albeit without colored labels).

Anyways that’s not the solution.
I have propably marked a million files with colored lables,
and only having a tiny colored dot with my resolution 5120x2880, isn’t helpful at all.

I’ll wait!

@akemin_dayo, What is the status of TF working in macOS 13.x Ventura? I haven’t upgraded from Monterey yet because I don’t want to lose TF and its tabbed window interface. Can you give us an update on where we are and what we will need to do locally to make TF work?

A little bit up in the thread the dev posted this:

Granted that post was 21 Days ago. A couple more days before that:

Not saying that people haven’t gotten many things to work with Ventura, but that could mean they lucked out with a more compatible machine.

So maybe we’ll hear something shortly? :crossed_fingers:

1 Like

Hello!

I’ve monitored this forum and already tried everything to start TF on Ventura 13.1.

Today I installed Recording Indicator Utility (GitHub - cormiertyshawn895/RecordingIndicatorUtility: Recording Indicator Utility lets you turn off the orange microphone recording indicator light for live events and screencasts.) and I disabled this thing by following instructions - csrutil authenticated-root disable, and after reboot, TF started.

This is an instruction that I followed: Modify Security Policy

My mac: 16’ M1 Pro base

Thanks I’ll try it asap!

Does cmd+x also works?

No, cmd+x and colored labels doesn’t work

But regular insert+cut works by ⌘ + ⌥ + V

Yes yes I know, I just wanted to ask which feature works and which not

@eBara @RickO @Thommy

Here’s a very quick and unpolished writeup regarding the compatibility of the current public build of TotalFinder 1.14.3 and macOS 13.0.1 22A400 Ventura.

What does not work (public 1.14.3)

  • [※ SEVERELY IMPACTS USABILITY] Having TotalFinder enabled at all causes some context menu actions to disappear from the Finder right-click menu, regardless of whether or not any TotalFinder context menu tweaks are actually enabled.
  • The entire Cut and Paste feature, including the Command-X keyboard shortcut as well as the custom context menu buttons.
  • Copy Path context menu actions do not appear.
  • Having Coloured Labels enabled at all will cause TotalFinder to completely crash.
    • ※ If you find yourself in such a state, you can manually disable the feature in Terminal using defaults write com.binaryage.totalfinder TotalFinderLabelsEnabled 0

What works (public 1.14.3)

  • Replacing the Finder Dock icon with the TotalFinder Dock icon
  • Keeping the original Finder Dock icon (or a custom one set via another tweak)
  • Showing a progress bar for file operations in the Dock icon
  • Menu bar item
  • Colourful sidebar, including Finder icon rendering mode (※ some custom disk icons may not display correctly)
  • Auto-adjusting column sizes in Column View
  • Quick-toggling hidden files
  • Visor
  • Tabs
  • Dual View
  • Compatibility with OpenCore and OpenCore Legacy Patcher
  • Compatibility with Apple Silicon (※ requires additional -arm64e_preview_abi boot-arg to be set for now)
  • Compatibility with Intel / AMD (x86_64)

@ChrisOSX @ChrisSpera as well as everyone else patiently waiting for macOS 13 support:

With the current progress in my internal development build, I’m aiming a hopefully-usable beta or something in around a week’s time. Thank you your patience and understanding.

(※ Unlike the previous estimate, this is somewhat based in reality instead of Baseless Guessing™ ;P)

6 Likes

@zerojj @eBara

Disabling authenticated root is NOT required for TotalFinder to work.

The reason why TotalFinder started working on your system after following the instructions for Recording Indicator Utility is because its instructions had you completely disable SIP via csrutil disable beforehand as part of disabling authenticated root.

I do NOT recommend disabling authenticated root unless if you absolutely have to for another tweak (※ or are using OpenCore/Clover). Doing so puts you at an elevated risk of making your system unbootable and/or breaking system updates. TotalFinder does NOT require authenticated root to be disabled.

3 Likes

Thank you very much for your amazing work on it! :blush:

(And of course for your patiently well explained answers)

1 Like

That’s exciting that we might have a beta in a week or so. That’s wonderful. Thanks so much!

1 Like

I have a rather interesting problem. Open TF, perfect. Open second tab and I get a document that I examined about a month ago. Close that tab, open a second tab, same document. Uninstall TF, reinstall TF, open it, one tab? Perfect. Open second tab? Same document appears. I don’t even want that second document anymore. ARGHHH!!

1 Like

For us folks running OpenCore Legacy Patcher, this is not an option. But adding “CSR_ALLOW_TASK_FOR_PID” in the SIP settings is all you recommended before, I still receive the Injection error. Reverting root patches makes TF work again, but I lose other things I need.

I’m on Monterey 12.6.2, with no foreseeable ability to update to Ventura, unless the devs come up with some tricky stuff for us non-metal machines to update.

I’m nothing but patient, and can help where I can, Just let me know.
Keep up the good work! :+1:

@Ken

Huh, what do you mean by “a document appears”? Do you mean Quick Look? What macOS version is this occurring on? My best guess is that this may be some kind of strange Saved Application State behaviour related to Finder…


@ChrisOSX

Ah oops, I clarified the original message a bit to “I do NOT recommend disabling authenticated root unless if you absolutely have to for another tweak (※ or are using OpenCore/Clover).”

It was really only meant for people using supported Apple hardware, since disabling authenticated-root on those platforms leads to a whole bunch of headaches like OS updates no longer working, etc.

But for us in Unsupported Hardware Land™, anything goes ;​P


@ChrisOSX

So, regarding this…

Let’s first establish what “OpenCore” is:

  • OpenCore, an UEFI bootloader that is capable of booting:
    • macOS on supported Apple hardware
    • macOS on unsupported (legacy) Apple hardware
    • macOS on generic non-Apple hardware
    • Any other UEFI-compliant operating system, such as Windows (bootmgfw) or Linux (GRUB)
  • OpenCore Legacy Patcher, a set of rootFS patches that allow a booted macOS system to better work with legacy Apple hardware by injecting necessary kexts and applying other patches/fixes to various parts of the macOS operating system

I can actually personally confirm that TotalFinder works totally fine with:

  • The OpenCore UEFI bootloader, configured to disable the SIP flags CSR_ALLOW_TASK_FOR_PID and CSR_ALLOW_UNRESTRICTED_FS and booting the following macOS versions:
    • macOS 13.0.1 22A400 Ventura
    • macOS 12.6.1 21G217 Monterey
    • macOS 11.7.1 20G918 Big Sur
    • macOS 10.15.7 19H2026 Catalina
    • macOS 10.14.6 18G9323 Mojave
  • The OpenCore Legacy Patcher root patches for my MacBookPro12,1 to allow proper GPU acceleration on macOS 13.0.1 22A400 Ventura (※ which basically only involves injecting the required kexts for the Intel Broadwell IGP into the rootFS snapshot)

From this behaviour, we can conclude the following:

  • OpenCore (the bootloader) is not the cause as TotalFinder works fine with it.
  • Running a system with an unauthenticated rootFS snapshot (required for all OpenCore root patches) is not the cause.
  • This behaviour is most likely being caused by some patch, kext, or other step that is required specifically for your MacBookPro6,2.

That being said, it just so happens that one of my friends, she actually has an old MacBook Pro that… may be the same as (or at least similar to) yours — in that we know for sure it’s a A1286 but are unsure if it’s a MacBookPro6,2 or simply another similar model, and I won’t be able to tell until I help her get an OS onto it to read the SMBIOS info.

If it is the same machine (or a similar enough one) and I can reproduce the issue, that would be the best outcome and I can try to fix whatever the issue is either on TotalFinder’s side, or help coordinate with the OpenCore team / Dortania to fix the issue upstream.

If not, then I will probably ask you for some debug logs from OpenCore, Lilu, and the OpenCore Legacy Patcher TUI, as I’m determined to get this working for you one way or another. o)-<


For everyone else, here’s a preview screenshot ;​P

(※ Screenshot is of my Intel test machine with all features enabled for testing purposes with the exception of Coloured Labels. The erroneously duplicated disk in the sidebar is actually an issue with Finder, and not TotalFinder. The inconsistent behaviour regarding custom disk icons for macOS >= 10.15 is a known issue, and happen due to some technicalities regarding how Apple handles APFS volume groups in Finder.)

2 Likes

Karen, The second tab opens in Quick Look. in my Documents folder. I’ve tried changing the folder, changing the document (always comes back with the same document), deleting TF with the uninstaller in the TF program, deleting TF with my armageddon strength application delete program, rebooting and then reinstalling and there it is again in Quick Look mode. I fixed it by moving that sub-folder it insists on opening every time and now it’s returned to the “Recent” folder list. Not sure what caused it, if I really fixed it or it was just a quirk. None the less it’s opening a standard second tab now. Oh, Version 13.1 Beta (22C5050e).

I can confirm that TF does indeed work, however, you can see in screenshot which root patches OCLP is trying to install. Also, you can see my build SIP settings include all the necessary flags disabled for OCLP and TF.


I reverted patches, installed TF and it works. But applying root patches does something for some unknown reason to cause the injector error
Screen Shot 2022-11-30 at 4.18.00 AM

This may be the case here. :man_shrugging:

Just let me know what you need :slight_smile:

1 Like