Wake from Sleep Doesn't Always Wake with TotalSpaces2 Running

I very much like TotalSpaces and now the new TotalSpaces2. But there was a problem with the original TotalSpaces that I had hoped would go away but didn’t with TotalSpaces2: sometimes my Mac does not wake from sleep when TotalSpaces2 is running – I have to do a hard shutdown (pressing the power button for 5 seconds).

Attempting to wake in this circumstance has no effect. The Mac does not wake. Period. ⌘^␛ does not bring up the Force Quit task manager. The screen is black. It seems that the time during which the Mac must be sleeping has to be at least 8 hours before the machine freezes; I can sleep the Mac and wake it up after an hour or two with no problems.

@stephen, I read the thread on TS2 freezing (“Spaces frozen on Mavericks”) but this is apparently not the same issue. I’ve ‘recreated’ this problem on:

  • a late 2009 MacPro running Mountain Lion and TotalSpaces (original),
  • a brand new 2013 iMac running Mavericks and TotalSpaces2.

By ‘recreated’ I mean that I do the following:

  • leave TS2 running and let the Mac sleep for a lengthy period of time and experience the freeze,
  • then I quite TS2 for a week or more and let the Mac sleep for a lengthy period of time and the Mac does not freeze.

I’m going to run TS2 this week and see if I can get the iMac to freeze. Then I’ll go again a week without TS2.

@stephen, can you suggest what I should look for if when this iMac freezes again and I attempt to SSH in? What Unix command output would be helpful to you? ‘top’? What else?

Mike

Hello Mike,

This is pretty mysterious.

I’d love to see if there was anything in the logs - e.g. tail -200 /var/log/system.log

But also after reboot you should be able to scroll back to before the reset was needed in Console.app.
Hopefully there will be some clue in there.

This is really strange - I don’t really have any good idea what the cause could be. I mean, nothing is happening when the thing is asleep. Best guess - maybe something to do with the trackpad handling? Do you use swiping to change spaces? You might turn that off before sleep and see if the problem still occurs.

I am having this same problem, too. It started happening as soon as I installed the 2.017 upgrade this morning. I have had to disable TotalSpaces2. Is there any way to revert to the previous version? And/or troubleshoot?

Happily, since switching to my new iMac I have had no problems with TS2. The iMax wakes from sleep just fine. I suspect there must be some timing-related issue. My old MacPro was a decent machine for 2009 and it would wake and be available in 5 seconds or so but this new iMac wakes instantaneously. Of course, there could be any number of other differences that could contribute to the waking problem.

Some spelunking in your Console.app might reveal something.