Your help needed: please verify that cmd-X reliably cuts

In certain situations with some recent versions of TotalFinder, the keyboard shortcut for cutting files (command-X) was inexplicably getting disabled, even though it would work for some time.

In TotalFinder 1.4.17, which is still in beta, we believe we’ve fixed it. If you’re feeling up to it, please install the beta and see that cmd-X performs as expected for long periods of time.

I have 1.4.18 and I still have this bug. I need to right click on the file, then cmd+x works.

I’m having problems with the Cut function too, some times it works some times it doesn’t

@allaire and @kevdiaz, if you’re interested in trying the beta version 1.4.27, please give it a shot, as I think the problem is reliably solved:

However, if you don’t want to try beta software, please be patient as we’ll be releasing a full version in the next few weeks.

Actually version 1.4.27 is what I have, I’ve been running this version for a while, it still has the problem.