1.9.1 error on file deletion


#1

Ever since I’ve upgraded to version 1.9.1 I am getting the following error when deleting a file:

I already had TotalFinder installed according to the instructions here: https://totalfinder.binaryage.com/system-osax
Installed the update by just running the installer, reboot and disable OSAX when the installer asked, installed the component and turned it back on.

Any idea? Will now try to uninstall TF and try again from the beginning.

Using macOS Sierra 10.12.4


#2

I don’t think this is TotalFinder-related.

I would recommend to force-quit Finder.app via CMD+OPT+ESC. And then use vanilla Finder.app for the same delete operation. I guess you will see the same error.


#3

I’ve just tried this and no errors occurred. With TotalFinder enabled I do get this message occasionally. After this message the deleted file shoes up as ‘?’.

Will try to do a reinstall later tonight.


#4

I have uninstalled TF, removed the TotalFinder.osax file from /System/Library/ScriptingAdditions and reinstalled TF. Problem seems to be resolved :slight_smile: