BinaryAge

10.15.4 Public Beta 1 breaks TotalSpaces

I installed Catalina Public Beta 10.15.4 yesterday and TotalSpaces2 2.8.6 no longer works. I cannot change the desktop by choosing the desktop in the TotalSpaces menu or by clicking in the overview grid.

2 Likes

Yes, you are right, I notified Stephen yesterday about this, he is looking into it. :sunglasses:

any update news?
drives me crazy without TS. :rofl:

1 Like

+1 :+1:

It’s a testament to how awesome TS is. I’m fumbling around using the default Spaces and it’s ridiculous. Can’t wait to get it back so I can be productive again!

10 days up!

FWIW, I did an uninstall and then reinstalled TS from scratch thinking it might resurrect TS’ functionality. No joy.

I now have a fixed version, but as luck would have it the apple notarization service is down. I will try to push it out tomorrow.

AWESOME!!! THANK YOU, STEPHEN!!! :star_struck:

Way to go Stephen!

Please try this version (should be ok for 10.15.4 beta 3)

https://downloads.binaryage.com/TotalSpaces2-2.8.7.dmg

2 Likes

Thank you very much, stephen. It works! :+1:

It works! Thanks Stephen.

A big thank you Stephen for your continuous support on this great app (that, yes, Apple should compare with its own solution, not as productive, by far!)

Thank you

Is this version intended only for 10.15.4 ? I tried it with 10.15.3 and I could not change the desktop in the TotalSpaces menu or overview grid; additionally, it removed the menubar on the secondary (non-primary) display. I also could not create desktops through TotalSpaces.

Attempting to switch to a desktop would sort of “blink” the menubar and cause the dock to restart. Note that this the behavior after a full csrutil --disable

10.15.3 and 2.8.7 and I have the same behavior. Can’t change spaces, can’t create new ones and sometimes they disappear from the list.

Please try 2.8.8 https://downloads.binaryage.com/TotalSpaces2-2.8.8.dmg

Hi stephen,

I’ve tried version 2.8.8 on MacOS Catalina 10.15.3 Beta and it doesn’t seem to work. Uninstalled twice, rebooted after uninstalling and reinstalled. Nothing seems to work.

Switching desktops only works with the default mac behaviour, and this is what happens on the layout tab in preferences: https://i.gyazo.com/772bafdf447686f014d823b2175ed05e.gif

Hope it’s easy to fix, thanks!

I have the release of mac OS Catalina 10.15.4 and just installed your version 2.8.8. Previously nothing on the TotalSpace’s Transitions tab seemed to work. Now it all seems to be working again. However as I said I just installed the TotalSpaces update, so time will tell, but at least we are off to a good start.