BinaryAge

11.3 Breaks TotalSpaces?

Just updated my iMac to Big Sur 11.3. TotalSpaces2 now seems broken; can’t switch to another screen using Overview Grid.
Anyone else?

1 Like

I have the same issue. Upgraded from Catalina to Big Sur. totalSpaeces2 wants to control a dock (as usual). I turn it on in Preferences (Privacy) and restart TotalSpaces. Nothing happens. I lost my all configuration (desktops). But I cannot add any destotop because TS2 shows that I have already 16 desktops. Before I had only 4 desktops and never wanted more. Now in MacOS I swipe and can see 4 desktops.

Well, I had it working on Big Sur up until this morning’s update to 11.3. It still starts, but when I call up the Overview Grid and click on another desktop, it just comes back to the same desktop.

1 Like

macOS 11.3 2021-04-26 Update included some critical and very deep security patches which I would not be surprised slammed some of the backdoors TS2 uses.
I’m going to try disabling SIP completely again, see if that helps.

Updated: can confirm that totally disabling csrutil completely does not resolve the issue.
Well, this is not great. My entire use of this computer depends on TS2 :sweat_smile:

2 Likes

I hear ya! I was really enjoying TS2 as well; now I guess we have to be patient and wait for a version 3.0 release which will work with all the new stuff.

Hopefully soon!

Oh, but then, looking back at their blog about TS3, it appears it’ll be only for M1 Macs, leaving many of us stranded.

Hm. Might be time to look for an alternative, if there is one, or just learn to live with Mission Control…

Total Spaces 2 is also broken for me. Intel Mac mini (2018) running 11.3. It worked yesterday, no configuration changes made other than the macOS update.

Guys, check the updates page (pre-releases) - the latest version fixes it TotalSpaces2 Pre-releases

2 Likes

It does!!!

Thank-you for that!

#happyagain :smiley: :blush:

Thank you!

I am beginning to wonder if Apple is targeting this app and doing this on purpose.

It’s still broken for me… It keeps saying "Could not create all requested desktops. The system limit is 16 (plus specials). I don’t even have 5 desktops… anyone has this problem?

@Ken_Hui Nope, this pre-release version has worked fine on both my iMac and my Macbook Pro.

Same problem here (TS 2.9.8 running on macOS 11.3 w/SIP disabled): I get this message whenever I try to create more desktops. The issue does seem to be specifically with desktop creation – if I create the desktops in Mission Control, TS can manipulate them, but it can’t create any (not even a second desktop when I only have one).

@bysmuth yes… I ended up just create the desktops I need in the native Mission Control UI and then arrange them in TotalSpace 2… it’s annoying when you need to do a lot of them but it’s workable… I hope Binaryage can fix this soon!

Rock 'n Roll back in business here.
I can confirm that adding new Desktops fails with an error, but can be done via Exposé and they are then picked up by TS2.