5 seconds of random space switching each time macbook wakes from sleep

On my Macbook Air (mid 2012) running Mavericks I’ve started experiencing a problem with TotalSpaces2 in the last few months. Each time I wake the computer from sleep, it instantly begins switching randomly between spaces for about 30 seconds. After 30 seconds it stops on a space, and everything works fine again. Anyone else experiencing this or know of a solution?


Hi Erich,

I can’t think why that would be. What are your hotkeys set to?
Does it happen when you are running some particular applications?
Does this only happen when TotalSpaces is running?

First, a correction: after paying closer attention it’s really only about 5 seconds of switching. Still it seems like something that shouldn’t happen. It only happens after the computer has been asleep for several hours. It doesnt happen if I just close the lid and then open it after in a minute or so.

Is there a way to simulate a long sleep from the terminal, so I can test quickly whether it happens when Totalspaces or other applications are running?

Hotkeys are:
shift+option+arrow to change space
shift+option+space for overview grid
space bar to toggle expose. Nothing is set for move current window, mouse, or instant expose.

Update: I believe the sleep state from which the issue occurs is called standby. Normally the laptop goes into standby after 1.5 hours of sleep disconnected from the power supply. I was able to get it to go into standby about a minute after closing the lid, by entering the terminal command “sudo pmset -a standbydelay 0”. I close the lid, disconnect the power cable, wait a minute, and when I open it’s waking from standby.

I tried this several times with totalspaces running and it did the random switching thing a few times, but not every time. Sometimes it would just move one space over when it woke up, sometimes it didn’t switch any spaces at all, and a couple of times it switched spaces randomly for about 5 seconds. I then quit totalspaces and tried waking from standby several more times. It never did any random switching when totalspaces wasn’t running.

I’ll try this again in a day or two when I get some time to really experiment with it. The programs I’m currently running are safari, calendar, excel, and tap forms database. Thanks for your attention to my problem.

(edited because autocorrect messed up the terminal command: it’s “standbydelay” not “standby delay”)

Thanks for your investigations.

Unfortunately I still don’t understand why this is happening.

Is there anything in the Console.app logs that might indicate what’s going on?

If I understand the question correctly, you’re asking to check the logs in Console (under utilities)? I opened Console and searched where it says “string matching” for terms such as totalspaces, total, spaces, binary age, binary, etc. Nothing showed up. I looked through the log list (left hand column) and opened all the ~/Library/Logs lists, but couldn’t find anything that obviously relates to TotalSpaces.


In Console.app you should be looking at All Messages from the left column.
I would expect to see something at least resulting from a search for TotalSpaces, but searching for Dock may also be useful.

If you find nothing there, then I find myself wondering about the trackpad - do you have TotalSpaces set up for trackpad swiping to change space?

OK, for some reason now a lot of log entries show up from a search for Totalspaces in the Console. Maybe it’s because I looked under All Messages (thought I did that before). Anyway, I captured about 7 screens of logs relating to Totalspaces. Most of them say “TotalSpaces2[20138]: DO proxy exception NSDistantObject (0x608000276500) is invalid (no connection)”

Each entry can be opened to reveal more data but from what I can tell most of them say the same thing. Here are the first and last screenshots, and one with an entry opened up to give details:

By the way I do have Totalspaces set up for trackpad swiping with 3-finger swipe to switch spaces.

Thanks. Those logs say that the Dock process was not responding to TotalSpaces, so it was automatically restarted. That shouldn’t in itself cause the space to change, but clearly it is indicative of something awry.

I wonder if TotalSpaces is too aggressive about restarting Dock. I’ll try to make a new build that doesn’t do this until after a longer timeout. I’ll get back to you with this.