BinaryAge

Aesepsis 1.4.1 - Issue with Update, installing Xcode command-line tools

#1

Summary

Aesepsis 1.4.1 requires installing the Xcode command-line tools, but the installer for them failed for me due to a nondescript “network connection” issue. After some digging I found that the means that the installer uses to install the command-line tools no longer works, and you have to download them from apple’s developer directly.

I would therefore like to advise the Binary Age Devs to modify their updater to correctly reflect this information. Here is a detailed account of the process I went through:


The Problem

I’m using Mavericks 10.9.3 and Today I was prompted to install Asepsis 1.4.1, I had 1.4:

Clicking ‘Install Update’ downloads the update, and then clicking ‘Restart and Install’ runs the installer.

During the installation process I am prompted to Install Xcode command-line tools.

I have Xcode 5.1.1 installed and thought that I had previously installed them. Nonetheless, I continue by clicking ‘Install’, and after agreeing to an Apple license agreement it tells me that I ‘Can’t download the software because of a network problem’:

Asepsis’ Installer reminds me of the same fact and links to the OSX Daily article:

which includes a terminal command, xcode-select --install, which when entered in the terminal ultimately results in the same ‘network problem’ error.

Furthermore looking at my installation of Xcode, in the Downloads tab it does not display Command Line Tools as an available option:

As a result I was unable to update Asepsis to 1.4.1 with the instructions provided by the updater


The Solution

After some digging I ran into this Stack Overflow topic: http://stackoverflow.com/questions/19066647/xcode-5-0-error-installing-command-line-tools which claims that “The command line tools are no longer available via Xcode.” for Xcode 5.0.1 and Mavericks 10.9, and that you have to download it directly from apple’s developer page: https://developer.apple.com/downloads/index.action

After logging in with my AppleID I was able to successfully download and install the command-line tools for Mavericks, April 2014:

After restarting I was then able to successfully update Asepsis to 1.4.1

#2

Hi Johannes,

Than you for your detailed report. I have tested the installer on my machines (clean 10.9.2 and 10.9.3 installs) and for me the installer worked as expected. This must be some glitch or isolated problem. I will wait for more reports like this.

Thank you for documenting an alternative way how to install the command-line tools.

Just for a reference, there is another discussion thread on Github about 1.4.1:

#3

Hi. I just upgraded to Yosemite 10.10.3 (yes, I know, late, 10.10.4 is nearly out, but I had reasons…). Anyway, I ran into the same problem. After the update Aesepsis told me I may have a problem, and I confirmed it was no longer working (visually - with show invisibles on, .DStore files started to appear in directories). I downloaded and installed the latest version of Asepsis (1.5.1) and got the “Please install Xcode command-line tools” dialog as seen above. When I went to the supplied link and followed the instructions, I got this:

$ xcode-select --install
xcode-select: error: command line tools are already installed, use "Software Update" to install updates

Software Update showed nothing to update.

As per above, I downloaded and installed the latest command tools manually (Command_Line_Tools_OS_X_10.10_for_Xcode_7_beta_2). This made no difference.

When I try to install Asepsis all I get is the the “Please install Xcode command-line tools” dialog.

Any idea how I can fix this?

Thanks!

#4

I think you can disable the check by creating this file:

touch ~/.skip-asepsis-codesign-check