Bug: Finder overlay appears out of nowhere

For the past few versions of TotalFinder, when I cmd-Tab to Finder, a strange overlay of a Finder window appears, instead of TF Visor (see screenshot below). This overlay can’t be moved, resized, or altered/interacted with in any way, and neither can it be closed (other than by killall Finder). I can still access TF with my Visor shortcut.

Any idea what’s causing this, and how to fix it? Thanks.

I just tried doing a clean install of TotalFinder, and now it’s not working at all. When I run TF, Finder stops responding altogether. I used the official uninstaller and even tried removing all traces of TF with UninstallPKG, with no luck. Help!

Can you look into Console.app? Are there any error messages (related to Finder/TotalFinder)

Also maybe you’ve hit this issue:

Try this workaround:

1 Like

Some good news, though Console doesn’t reveal a lot:

28/07/2014 15:50:30.761 TotalFinder[7993]: agent v##VERSION## started (TotalFinder) 28/07/2014 15:50:30.771 TotalFinder[7993]: Finder is not running. Launching it... (/System/Library/CoreServices/Finder.app) 28/07/2014 15:50:31.211 TotalFinder[7993]: requesting injection into com.apple.finder[7995] 28/07/2014 15:50:32.219 Finder[7995]: TotalFinderInjector v1.6.2 received init event 28/07/2014 15:50:32.240 Finder[7995]: TotalFinderInjector: Installing TotalFinder ... 28/07/2014 15:50:32.241 Finder[7995]: Launching TotalFinderCrashWatcher from '/Library/ScriptingAdditions/TotalFinder.osax/Contents/Resources/TotalFinder.bundle/Contents/Resources/TotalFinderCrashWatcher.app' 28/07/2014 15:50:32.270 TotalFinder[7993]: TotalFinder has been succesfully injected into com.apple.finder[7995] 28/07/2014 15:50:32.291 TotalFinderCrashWatcher[8004]: Watching '/Users/antonio/Library/Logs/DiagnosticReports' for new crash reports with prefix 'Finder'

At this point, Finder had stopped responding. However, I copied and pasted your suggested tweak, and Finder came back to life. It looks like TotalFinder is working, as well! I’ll let you know if the “overlay” comes back.

Thanks! Hopefully this will have solved it.