Cannot assign Eclilpse to a particular workspace

I don’t know how this happened. Whenever I open Eclipse (4.2), it opens on Workspace 1. Only, I want it on Workspace 3. I open the TotalSpaces dialogue for assigning applications to workspaces and add Eclipse. There is no entry for Eclipse. As soon as I have picked Eclipse (the which resides in /Applications/Eclipse), it appears and immediately disappears again.

Thus I currently cannot assign it to the Workspace I want, but also have it (how ever I did that) assigned to a workspace where I just don’t want it. I took a look at the preferences plist file in xcode, but I could not find any reference to workspace assignments there. Any hint?


Please try to assign it to the workspace you want using the Dock method:

Ctrl-click on the icon in the dock, and choose Options->Assign To ->This desktop.

Does that work?

1 Like

Thank you for this hint. Unfortunately it does not help. The effect I’m getting now is this: when opening Eclipse, I get warped to my Workspace 3, but Eclipse still opens in Workspace 1 - even if I choose “no desktop” in the dock.

Does the same thing happen when TotalSpaces is not running?

(It probably does, it’s likely something between OSX and Eclipse, but it would be good to check to make sure it’s not some bug in TotalSpaces that causes it).

Yes, it’s the same when TotalSpaces is not running.

Right. So it’s some interaction of Eclipse and OSX. Is there anything about it on the Eclipse forums (or mailing lists or whatever they have)?

It may also be useful to look at ~/Library/Preferences/ - that’s where the app-space bindings are stored. Perhaps something went awry in that file?

I found an entry there: “org.eclipse.platform.ide” with no assignment. I deleted it and hard-killed dock, made sure it was really gone after Dock was back, but next time I ran eclipse, I had the same behaviour, and the entry was back.

Ah, Mavericks has very aggressive caching of prefs.

Remove the entry, save the file, then reboot your machine. After that the cache should be gone.

(I don’t know any better way).

Did so. No effect. But also - my system is Mountain Lion, not Mavericks.

OK, fair enough. By the way, under Mountain Lion, if the entry appears to have no assignment (no space UUID), it means space number 1.

So, somehow eclipse is getting into the space assignments by itself. I don’t know why that would happen - I can’t imagine this was something the eclipse developers did deliberately.

Is there any eclipse support or forum that may be able to advise?

I just upgraded to Mavericks and Total Spaces 2. Now I can assign Eclipse to workspaces just fine. Thus for me the problem is solved.

Ok, that’s great to hear!