Can't change activation key to control-esc

Can’t change activation key to control-esc.

I know historically (in later versions) Cmd-Escape couldn’t be set either. It’s possible Ctrl-Escape doesn’t work for the same reason. There was a work-around for Cmd-Escape by editing the plist file. I’ll dig it up. I suspect it would need to be modified for Ctrl-Escape.

I can confirm the issue. I did a bit of research.

  1. Historically TT was using Shortcut Recorder from Waffle Software[1]
  2. Since TT 1.5 I have switched to MASShortcut Recorder[2], because it is more modern and actively maintained

I did some debugging of this case and I think they have a bug MASShortcut and this case should be supported.


Created a pull request:

This fix will be available in TT 1.5.3 (in a few hours)

Resolved in 1.5.3:

Please confirm.

Hey Antonin,

Thanks for this, this is definitely a big improvement! Confirmed that Ctrl+Esc does indeed work now.

However, Cmd+Esc still doesn’t, but I think it may be a different issue. When I try to set Cmd+Esc, I still get a warning that it’s already used by a system-wide keyboard shortcut. On Mavericks, it’s not actually taken by anything, but possibly is still reserved for Front Row?

The old plist editing trick no longer works either, it always reverts back to the hotkey I set through MASShortcut upon relaunching TotalTerminal.

Still, like I said, this is definitely an improvement. Thanks again, and congrats on being a contributor to MASShortcut now :stuck_out_tongue:

@nickjs New TotalTerminal 1.5.4 should resolve the problem with conflicting global shortcuts which are in fact disabled.

I have implemented also a hack, which will allow you to assign a shortcut anyway. Just for case you want to try it and think global shortcut won’t have effect/precedence.

:+1: :sheep: :dash: :+1: The hack works perfectly, thank you so much. Now I just need to retrain my retrained muscle memory :smile: