Can't open Trash


#1

Just like that and out of nowhere. Since this afternoon I simply can’t open it when TotalFinder is running.

Most of the times, trying to open Trash from the dock results in no action whatsoever. Some other times I’m luckier and it produces a weird-looking Trash window that I can’t interact with nor close. I’ve tried relaunching TotalFinder and rebooting the OS and it’s still the same.

A screenshot of the weird-looking window here:

The only thing I’m yet to try is reinstalling TotalFinder, but since this seems a very weird bug, I’m willing to stay like this a bit longer if my logs can help figuring out what the problem is.


#2

+1 Same here

This problem is annoying, hence I really appreciate feedback from support. I experience same issues omegak described. Attached a screenshot how my trash looks when opened. It looks like the finder panel is missing the surrounding window. The “panel” can not be moved, nor closed. I am using OS X 10.10.3.


#3

I am having exactly the same issue :smirk:


#4

I’m having the same issue. The trash icon on the dock does nothing when I left click it. I can right click on it to bring up the context menu, but the options there do nothing when selected. Has there been any update on this?