BinaryAge

Clicking Finder Icon in Dock no longer works as expected

After updating to os x 10.10.3 clicking the Finder icon in the dock doesn’t “show” or maximise the window finder window to the desktop. Have tried to uninstall and re-install and the behaviour remains the same. I’m pretty sure this worked before the os x update

2 Likes

I also have this problem which seems trivial, but actually in Daily use is very inconvenient having to right click the finder dock icon to re-open the finder window. I can confirm this worked before the OSX 10.10.3 update

Ditto this issue. Confirm it worked properly prior to OS X 10.10.3 update

Registered to make this same complaint. Must have happened very recently. I tried searching, and couldn’t find anything related to restoring after minimization.

CMD-Tab’ing doesn’t even work for me. I use Hyperdock, and hover over the icon to get the preview, and click that to restore the window.

Same complaint. Reduces productivity of Total Finder by at least 50%. You fix, yes?

I have been experiencing the same problem and it is really quite annoying

1 Like

I’m having the same issue since updating to 10.10.3

Are there any team TotalFinder members involved in this forum? Would be great to get an acknowledgement or request for further detail…or something.

1 Like

I second this issue. It’s getting annoying over time.

I wonder, if someone from the dev team is reading this. A short “we are aware of this” would be a great step forward. Ignoring us doesn’t help anybody.

The issue started directly after the 10.10.3 update.

1 Like

I think as paid for software we should reasonable expect some response. Not sure what we can do about it though?

1 Like

same here, as stated in another thread the problem seem to be related when visor is active.
could you confirm?

No, can’t confirm. My visor is deactivated.

same for me, I used to have visor activated and I opened/closed Visor just clicking the icon. Now it doesn’t work any more, I have to open with double option and close the same way or with esc key. Productivity is lessened by 50% this way, I hope binary age will listen to us and publish a problem solving update ASAP

Same issue here too. If the Finder window is minimized, and I click on the Finder icon in the dock, TotalFinder fails to relaunch the window. I have to right click on the icon now to select the Finder window I have open.

I have recorded this bug in a video so your development team can see it in action. In it I compare the default Finder behavior, to TotalFinders incorrect behavior.

I’m looking into it right now. It looks like internal Finder logic handling clicking the Dock icon changed in 10.10.3 and my code gets no signal about it.

Looking for a solution.

1 Like

Thanks for looking into this @darwin, and I appreciate the quick response via Twitter on this as well.

Thank you @darwin

Good news! I have just released a new version, which should address this issue:
http://totalfinder.binaryage.com/beta-changes#1.6.18

It would be great if you could test it before I release it to everybody.

2 Likes

Seems to be working again, thx!

Thanks @darwin !!! I verified this fixes the issue for me ( 10.10.3 )