Color sidebar icon support on 1.7.4?

I am just keen to know when the color sidebar icon will be supported?

I don’t plan to support it, because the coloured sidebar icons are no longer present under El Capitan.

Users would have to copy it into the system from older systems. I don’t own rights to those icons to include them in TotalFinder installation.

Could you at least provide a way to customize the sidebar icons? I have them from my previous system and eager to apply them to the new one. I turned off SIP and tried color sidebar icon simb plugin. Unfortunately, it doesn’t work.

Or could you tell me what icons I need to replace in the new system? In the old one , they are toolbarxxxicons in /System/Library/CoreServices/CoreTypes.bundle/Contents/Resources/. In the new one, there are no such icons. Should I replace the sidbarxxxicons? They doesn’t look like the right choice.

I’m sorry. I don’t have time to figure out this stuff at this moment. I don’t use El Capitan with modified icons.

I found a way how to re-implement it. My assumptions about icons were wrong. They are still present in the system.

Colorful sidebar is back in v1.7.5:

Under Yosemite (not El Capitan), 1.7.4 sidebar was working fine, it would display my custom icons that I had copied to /System/Library/CoreServices/CoreTypes.bundle/Contents/Resources/, replacing the Apple default icons for such things as MusicFolderIcon.icns and DesktopFolderIcon.icns.

However, with 1.7.5 and 1.7.6 which was changed to support El Cap, it seems to have broken under Yosemite, where it no longer shows MusicFolderIcon.icns and DesktopFolderIcon.icns, but shows a generic blue music note icon for Music and a generic monitor display icon for the desktop. Also, it shows a small size icon even if sidebar size is set to medium or large. Went back to 1.7.4 and sidebar now working correctly on Yosemite, displaying all the custom icons correctly. Perhaps 1.7.5 and later should only be for El Capitan

Thanks for reporting this, Michael. I will look into that tomorrow. It is likely some mistake on my side.

I just downgraded to 1.7.4, from 1.7.6 but had to make sure I trashed the SIMBL plugin at HD:Library:Application Support:SIMBL:Plugins:cDock.bundle the version installed by 1.7.5 & 1.7.6 does not get replaced, even after using the TF Uninstall Utility. I’m back to where I was, thankfully, but do hope you can fix this going forward. Not being able to have custom color icons defeats the purpose of color icons.

Is it sad to say, it’s one of the reasons I reverted back to 10.10 from 10.11? Total Finder wasn’t working. Glad you are continuing to work on it. : )

TotalFinder has nothing to do with cDock.bundle. It must be some other SIMBL plugin:

Ok, the change in behaviour was caused by introducing new icon mapping:

It differs from:

This mapping file is hard-coded mapping from some known folders to some known icons (so people don’t have to set custom icons to individual folders manually). This mapping has precedence before any custom-assigned icons or standard icons.

The problem was: since 1.7.5 I have applied icons2 in Yosemite and later and icons for previous systems. Which changed behaviour for you under Yosemite.

In 1.7.7 I will apply icons2 to Capitan and later and leave Yosemite with previous file. This should fix your problems under Yosemite.

If you ever wanted to override this plist mapping. You can create .totalfinder-sidebar-icons.plist in your home folder with copy of one of those files and tweak it. TotalFinder will use that one instead.

Version 1.7.7 is out on beta channel:

Some colorful icons are not right, inlcuding the Document and Download Folder(not the right icon) and Airport Timecapsule and all external disks(not colorful icons)

I am using 1.7.10 on OSX 10.11

You are right, we don’t have colour icons for every possible sidebar icon :-/

I think we do have color devices icons as you can see in the icon view we have this:

However I have no idea where these color icons are located. I have tried /System/Library/CoreServices/CoreTypes.b­undle/Contents/Resources, They seem to be not there. Any clue?