Could TotalSpace2 occassionally interfere with shortcuts for Mission Control and Application windows?

I have noticed that sometimes all of a sudden the shortcuts for Mission Control (F9) and Application windows (F10) stop working. They start working again when I log out of the account and log back in. Things are fine for a while and then it happens again. I can’t say that TotalSpaces2 is causing it, since TotalSpaces2 continues to work without a problem. But I thought maybe there is a connection.

This happened today on two accounts on my Macbook Pro.


I really can’t think of a way this could happen, unless TotalSpaces2 has similar shortcuts set up.

It may be interesting to see if quitting TotalSpaces2 then restarting it helps. But note, this will cause Dock to restart, so if the problem is within Dock then this may fix it even if TotalSpaces2 has nothing to do with the issue.

(the Dock program runs Mission Control as well as the Dock itself.)

Thanks. Next time it happens, I’ll try quitting TotalSpaces2 to see if it makes a difference. I’m open to suggestions on how to isolate the problem.


Hi Stephen,

An update on this. It happened again this morning, i.e. shortcuts for Mission Control (F9) and Application windows (F10) stopped working. To see if quitting TotalSpaces would help, I quit the application and now the shortcuts work. Since merely by quitting TotalSpaces the shortcuts began to work, it’s suggestive of a connection.

(The Macbook had been restarted on Sunday, so TotalSpaces had been running 2-3 days prior to the shortcuts stopping to work. I’m running OS X 10.9.5.)


OK. maybe it started working because Dock restarted rather than TotalSpaces, but at this point either is possible.

When this happens again, try killing TotalSpaces2. Go to Activity Monitor and find TotalSpaces2, then quit it from there. This will avoid restarting the Dock. If the F9/F10 restart working then you can probably lay the blame on TotalSpaces2. If they don’t I suspect it’s not anything to do with TotalSpaces2.

I still can’t think of any mechanism this can happen, but if you do end up thinking it’s TS2, it would help if you could email me your config file from ~/Library/Preferences/com.binaryage.TotalSpaces2.plist (to

OK, I’ll give it a try next time.


I tried what you suggested, i.e. when the Mission Control stopped responding, I killed TotalSpaces2 in the Activity Monitor. Mission Control still didn’t work. (Could it be that Mission Control was in a bad state and also needed to be restarted?)

Then I restarted TotalSpaces2; it worked but Mission Control still didn’t.

Then I quit TotalSpaces2 normally (i.e. didn’t kill it); previously quitting TotalSpaces2 would fix Mission Control. But this time, after I quit, the desktop became gray, and the dock disappeared. So killing TotalSpaces2, changeds the behavior of TotalSpaces2 Quit.

Right now Dock, Mission Control, and TotalSpaces2 none of them are working and logging out of the account seems to be the only fix.


It looks like Mission Control (which is handled by gets into a strange state.

At this point I don’t think it’s because of TotalSpaces2.

You can indeed do things the other way - next time it happens you can kill from the activity monitor (might need to force quit it, or just do killall Dock in a Terminal window). Dock should restart by itself - I bet that fixes the problem.

I’m not sure what happened when you quit TotalSpaces2 (which kills and Dock didn’t come back - should normally restart by itself, so this also a little suggestive of another problem.

Thanks. I’ll give ‘killall Dock’ a try next time. I seem to remember that when I did that sometime ago, things became unstable. But I’ll try it again the next time Mission Control acts up.


When you kill Dock like that, it should come back, but TotalSpaces will take a short while to notice and to re-install the plugin. But everything should clear up pretty quickly.

I do this many times a day when I’m developing :slight_smile: