Ctrl+number direct shortcut to a space not working

I can’t get the Ctrl+number direct shortcut to a space to work on my Apple keyboard’s numeric keypad. It works however on the number keys above letter keys. Does anyone know what I may have missed? I have enabled the “Switch to Desktop” shortcuts under Mission Control Keyboard Shortcuts. And Ctrl+arrows are working normally.

I’m not sure about this - if you turn off the shortcuts in Mission Control Keyboard prefs, and just use the TotalSpaces hotkey prefs to assign them, does it work?

Hi, if I turn off “Switch to Desktop 1” etc. in Mission Control Keyboard Shortcuts under Keyboard Preferences, then CTRL+Number keys (above letter keys) stop working as well as the keys on the numeric keypad. So it seems like this function came from Mission Control, not from TotalSpaces. I don’t see a way to assign CTRL+Number Keys in the “Hotkeys” prefs in TotalSpaces. Only for the arrow keys (which works great). Perhaps that is what’s missing?

However, I think that CTRL+numeric keypad works on my Mac Pro at home but I can’t check for sure since I’m traveling for two months. But I’m 100% sure that at least it worked in the past.

Perhaps all we need is at setting under “Hotkeys” for the 10 number keys and the 10 number keys on the numeric keypad, just like for the arrow keys, and the turn everything off in Mission Control prefs?

I’m using TotalSpaces 1.2.11 with 10.8.5.

Ah, sorry I misunderstood.

I think under 1.2.11 you should be able to assign to individual spaces by clicking on the blue spaces buttons in Layout prefs.

Let me know if that works.

Wonderful! That worked! Thanks!

Hi again,

I just upgraded to Yosemite and TotalSpaces 2, and the keyboard shortcuts on the numeric keypad stopped working. Please let me know if I’m missing something or if it’s a bug. I have assigned individual spaces by clicking on the blue spaces buttons in Layout prefs, but nothing happens when I use the assigned shortcuts. I just get the “error sound” that you hear when you’re trying to use a keyboard shortcut that is not in use.

I have tried many different keyboard shortcut combinations and with the shortcuts in Mission Control prefs on and off but same result.


Sorry for this - the solution may be as simple as quitting and restarting TotalSpaces2 - there was a bug that was causing newly set hotkeys to not function if the layout had been expanded after TotalSpaces2 was started. (The bug is now fixed in the pre-release version.)

Thanks! That worked! But after I quit and assigned the shortcuts, only 1-3 out of 9 desktops worked. I then had to quit again to get it to work.

I also wanted to take this opportunity to thank you for creating TotalSpaces. “Spaces”, imo, was one of the best innovations for OS X ever, and it’s a mystery to me why Apple decided to abandon it. But thanks to you, we now have TotalSpaces. I really couldn’t use OS X without it as I have 9 desktops in a 3x3 grid that I switch between 100s of times a day. I also love the fact that TotalSpaces lets me eliminate the transition animations completely. This makes for a much faster and calmer work environment.

Keep up the good work!
Patrick S.

Thanks for your kind comments!